aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles/120-plug.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 17:26:27 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-24 09:40:46 +0100
commit49e81f9fe4bc6f060a74f5505eca2a1767058b0b (patch)
tree6fd55c3c79d0ca32bc410a376abc26344c845942 /target/linux/kirkwood/profiles/120-plug.mk
parent9a1f441ac81c0c2b96ec813a645bae4fc8792bf5 (diff)
downloadupstream-49e81f9fe4bc6f060a74f5505eca2a1767058b0b.tar.gz
upstream-49e81f9fe4bc6f060a74f5505eca2a1767058b0b.tar.bz2
upstream-49e81f9fe4bc6f060a74f5505eca2a1767058b0b.zip
kirkwood: clean up profiles, move to image makefile
Adds support for per-device rootfs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/kirkwood/profiles/120-plug.mk')
-rw-r--r--target/linux/kirkwood/profiles/120-plug.mk64
1 files changed, 0 insertions, 64 deletions
diff --git a/target/linux/kirkwood/profiles/120-plug.mk b/target/linux/kirkwood/profiles/120-plug.mk
deleted file mode 100644
index 0512aff450..0000000000
--- a/target/linux/kirkwood/profiles/120-plug.mk
+++ /dev/null
@@ -1,64 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/SHEEVAPLUG
- NAME:=Globalscale Technologies SheevaPlug
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core
-endef
-
-define Profile/SHEEVAPLUG/Description
- Package set compatible with Globalscale Technologies SheevaPlug board.
-endef
-
-$(eval $(call Profile,SHEEVAPLUG))
-
-define Profile/SHEEVAPLUGSATA
- NAME:=Globalscale Technologies eSATA SheevaPlug
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata
-endef
-
-define Profile/SHEEVAPLUGSATA/Description
- Package set compatible with Globalscale Technologies eSATA SheevaPlug board.
-endef
-
-$(eval $(call Profile,SHEEVAPLUGSATA))
-
-define Profile/GuruplugServerPlus
- NAME:=Globalscale Technologies Guruplug Server Plus
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-btmrvl kmod-btmrvl-sdio kmod-libertas kmod-libertas-sdio \
- wpad-mini
-endef
-
-define Profile/GuruplugServerPlus/Description
- Package set compatible with Globalscale Technologies Guruplug Server Plus board.
-endef
-
-$(eval $(call Profile,GuruplugServerPlus))
-
-define Profile/Topkick1281P2
- NAME:=Univeral Scientific Industrial Co. Topkick-1281P2
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata
-endef
-
-define Profile/Topkick1281P2/Description
- Package set compatible with Univeral Scientific Industrial Co. Topkick-1281P2 board.
-endef
-
-$(eval $(call Profile,Topkick1281P2))