aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-4.19/108-on100.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-06-12 01:14:25 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-06-12 01:18:52 +0200
commit000d400baa0af2e42c9a462e42df7dc9abde1ec7 (patch)
treea11c2dd570e8f02c4a141f135fc8db1e1d391ef2 /target/linux/kirkwood/patches-4.19/108-on100.patch
parentc4e727f01cc40bd57274d0b885b0f75cde9c4683 (diff)
downloadupstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.tar.gz
upstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.tar.bz2
upstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.zip
kernel: drop everything not on kernel version 4.14
* Remove testing patches for kernel version 4.19 * remove targets ar7, ixp4xx, orion Those targets are still on kernel 4.9, patches for 4.14 were not ready in time. They may be readded once people prepare and test patches for kernel 4.14. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/kirkwood/patches-4.19/108-on100.patch')
-rw-r--r--target/linux/kirkwood/patches-4.19/108-on100.patch171
1 files changed, 0 insertions, 171 deletions
diff --git a/target/linux/kirkwood/patches-4.19/108-on100.patch b/target/linux/kirkwood/patches-4.19/108-on100.patch
deleted file mode 100644
index 2f535955dd..0000000000
--- a/target/linux/kirkwood/patches-4.19/108-on100.patch
+++ /dev/null
@@ -1,171 +0,0 @@
---- /dev/null
-+++ b/arch/arm/boot/dts/kirkwood-on100.dts
-@@ -0,0 +1,158 @@
-+/dts-v1/;
-+
-+#include "kirkwood.dtsi"
-+#include "kirkwood-6282.dtsi"
-+
-+/ {
-+ model = "Cisco Systems ON100";
-+ compatible = "cisco,on100", "marvell,kirkwood-88f6282", "marvell,kirkwood";
-+
-+ memory@0 {
-+ device_type = "memory";
-+ reg = <0x00000000 0x20000000>;
-+ };
-+
-+ aliases {
-+ serial0 = &uart0;
-+ };
-+
-+ chosen {
-+ bootargs = "console=ttyS0,115200n8 earlyprintk";
-+ stdout-path = "serial0:115200n8";
-+ };
-+
-+ gpio_keys {
-+ compatible = "gpio-keys";
-+ pinctrl-0 = <&pmx_btn_reset>;
-+ pinctrl-names = "default";
-+
-+ reset {
-+ label = "Reset Button";
-+ linux,code = <KEY_RESTART>;
-+ gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
-+ };
-+ };
-+
-+ gpio-leds {
-+ compatible = "gpio-leds";
-+ pinctrl-0 = < &pmx_led_health_r &pmx_led_health_g >;
-+ pinctrl-names = "default";
-+
-+ health-g {
-+ label = "on100:green:health";
-+ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
-+ };
-+
-+ health-r {
-+ label = "on100:red:health";
-+ gpios = <&gpio1 13 GPIO_ACTIVE_LOW>;
-+ };
-+
-+ health2-g {
-+ label = "on100:green:health2";
-+ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
-+ };
-+
-+ health2-r {
-+ label = "on100:red:health2";
-+ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
-+ };
-+ };
-+};
-+
-+&eth0 {
-+ status = "okay";
-+
-+ ethernet0-port@0 {
-+ phy-handle = <&ethphy0>;
-+ phy-connection-type = "rgmii-id";
-+ };
-+};
-+
-+&eth1 {
-+ status = "okay";
-+
-+ ethernet1-port@0 {
-+ phy-handle = <&ethphy1>;
-+ phy-connection-type = "rgmii-id";
-+ };
-+};
-+
-+&mdio {
-+ status = "okay";
-+
-+ ethphy0: ethernet-phy@0 {
-+ /* Marvell 88E1121R */
-+ compatible = "ethernet-phy-id0141.0cb0",
-+ "ethernet-phy-ieee802.3-c22";
-+ reg = <0>;
-+ };
-+
-+ ethphy1: ethernet-phy@1 {
-+ /* Marvell 88E1121R */
-+ compatible = "ethernet-phy-id0141.0cb0",
-+ "ethernet-phy-ieee802.3-c22";
-+ reg = <1>;
-+ };
-+};
-+
-+&nand {
-+ status = "okay";
-+
-+ partition@0 {
-+ label = "u-boot";
-+ reg = <0x00000000 0x000a0000>;
-+ read-only;
-+ };
-+
-+ partition@a0000 {
-+ label = "u-boot environment";
-+ reg = <0x000a0000 0x00020000>;
-+ read-only;
-+ };
-+
-+ partition@c0000 {
-+ label = "kernel";
-+ reg = <0x000c0000 0x00540000>;
-+ };
-+
-+ partition@600000 {
-+ label = "ubi";
-+ reg = <0x00600000 0x1fa00000>;
-+ };
-+};
-+
-+&pinctrl {
-+ pmx_led_health_r: pmx-led-health-r {
-+ marvell,pins = "mpp45";
-+ marvell,function = "gpio";
-+ };
-+
-+ pmx_led_health_g: pmx-led-health-g {
-+ marvell,pins = "mpp44";
-+ marvell,function = "gpio";
-+ };
-+
-+ pmx_led_health2_r: pmx-led-health2-r {
-+ marvell,pins = "mpp47";
-+ marvell,function = "gpio";
-+ };
-+
-+ pmx_led_health2_g: pmx-led-health2-g {
-+ marvell,pins = "mpp46";
-+ marvell,function = "gpio";
-+ };
-+
-+ pmx_btn_reset: pmx-led-reset {
-+ marvell,pins = "mpp31";
-+ marvell,function = "gpio";
-+ };
-+};
-+
-+&sdio {
-+ status = "okay";
-+};
-+
-+&uart0 {
-+ status = "okay";
-+};
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -290,6 +290,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
- kirkwood-nsa310b.dtb \
- kirkwood-nsa320.dtb \
- kirkwood-nsa325.dtb \
-+ kirkwood-on100.dtb \
- kirkwood-openblocks_a6.dtb \
- kirkwood-openblocks_a7.dtb \
- kirkwood-openrd-base.dtb \