aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-4.14
diff options
context:
space:
mode:
authorPaul Wassi <p.wassi@gmx.at>2018-03-12 20:50:48 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-20 21:45:27 +0100
commit1447784a8c33145dd22dbe5f0c7bab56ab9b7d6f (patch)
treec372de1ef07b49a48c51b36d4262b48483266078 /target/linux/kirkwood/patches-4.14
parentf21cd9640052a733e1759519e3d7ca0f9453653b (diff)
downloadupstream-1447784a8c33145dd22dbe5f0c7bab56ab9b7d6f.tar.gz
upstream-1447784a8c33145dd22dbe5f0c7bab56ab9b7d6f.tar.bz2
upstream-1447784a8c33145dd22dbe5f0c7bab56ab9b7d6f.zip
kirkwood: add kernel 4.14 support
Add patches for 4.14, undoing upstream changes for Linksys devices regarding DSA. Instead, the switchdev driver marvell,88e6171 is used. Tested-by: Daniel Engberg <daniel.engberg.lists@pyret.net> Tested-by: Alberto Bursi <alberto.bursi@outlook.it> Signed-off-by: Paul Wassi <p.wassi@gmx.at>
Diffstat (limited to 'target/linux/kirkwood/patches-4.14')
-rw-r--r--target/linux/kirkwood/patches-4.14/100-ib62x0.patch30
-rw-r--r--target/linux/kirkwood/patches-4.14/101-iconnect.patch41
-rw-r--r--target/linux/kirkwood/patches-4.14/102-dockstar.patch32
-rw-r--r--target/linux/kirkwood/patches-4.14/104-ea3500.patch258
-rw-r--r--target/linux/kirkwood/patches-4.14/105-ea4500.patch121
-rw-r--r--target/linux/kirkwood/patches-4.14/105-goflexhome.patch130
-rw-r--r--target/linux/kirkwood/patches-4.14/106-goflexnet.patch23
-rw-r--r--target/linux/kirkwood/patches-4.14/107-01-zyxel-nsa3x0-common-nand-partitions.patch48
-rw-r--r--target/linux/kirkwood/patches-4.14/107-02-nsa310b.patch147
-rw-r--r--target/linux/kirkwood/patches-4.14/108-on100.patch173
-rw-r--r--target/linux/kirkwood/patches-4.14/109-pogoplug_v4.patch59
-rw-r--r--target/linux/kirkwood/patches-4.14/200-disable-tso.patch35
-rw-r--r--target/linux/kirkwood/patches-4.14/201-enable-sata-port-specific-led-triggers.patch10
-rw-r--r--target/linux/kirkwood/patches-4.14/202-linksys-find-active-root.patch62
14 files changed, 1169 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches-4.14/100-ib62x0.patch b/target/linux/kirkwood/patches-4.14/100-ib62x0.patch
new file mode 100644
index 0000000000..d1a5aa7d3e
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/100-ib62x0.patch
@@ -0,0 +1,30 @@
+--- a/arch/arm/boot/dts/kirkwood-ib62x0.dts
++++ b/arch/arm/boot/dts/kirkwood-ib62x0.dts
+@@ -6,7 +6,7 @@
+
+ / {
+ model = "RaidSonic ICY BOX IB-NAS62x0 (Rev B)";
+- compatible = "raidsonic,ib-nas6210-b", "raidsonic,ib-nas6220-b", "raidsonic,ib-nas6210", "raidsonic,ib-nas6220", "raidsonic,ib-nas62x0", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++ compatible = "raidsonic,ib-nas62x0", "marvell,kirkwood-88f6281", "marvell,kirkwood";
+
+ memory {
+ device_type = "memory";
+@@ -118,13 +118,13 @@
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x600000>;
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
+ };
+
+- partition@700000 {
+- label = "root";
+- reg = <0x0700000 0xf900000>;
++ partition@200000 {
++ label = "ubi";
++ reg = <0x200000 0xfe00000>;
+ };
+
+ };
diff --git a/target/linux/kirkwood/patches-4.14/101-iconnect.patch b/target/linux/kirkwood/patches-4.14/101-iconnect.patch
new file mode 100644
index 0000000000..ba81e169de
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/101-iconnect.patch
@@ -0,0 +1,41 @@
+--- a/arch/arm/boot/dts/kirkwood-iconnect.dts
++++ b/arch/arm/boot/dts/kirkwood-iconnect.dts
+@@ -146,28 +146,23 @@
+ status = "okay";
+
+ partition@0 {
+- label = "uboot";
+- reg = <0x0000000 0xc0000>;
++ label = "u-boot";
++ reg = <0x0000000 0xe0000>;
+ };
+
+- partition@a0000 {
+- label = "env";
+- reg = <0xa0000 0x20000>;
++ partition@e0000 {
++ label = "u-boot environment";
++ reg = <0xe0000 0x100000>;
+ };
+
+ partition@100000 {
+- label = "zImage";
+- reg = <0x100000 0x300000>;
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
+ };
+
+- partition@540000 {
+- label = "initrd";
+- reg = <0x540000 0x300000>;
+- };
+-
+- partition@980000 {
+- label = "boot";
+- reg = <0x980000 0x1f400000>;
++ partition@200000 {
++ label = "ubi";
++ reg = <0x200000 0x1fe00000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-4.14/102-dockstar.patch b/target/linux/kirkwood/patches-4.14/102-dockstar.patch
new file mode 100644
index 0000000000..7462b93e0c
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/102-dockstar.patch
@@ -0,0 +1,32 @@
+--- a/arch/arm/boot/dts/kirkwood-dockstar.dts
++++ b/arch/arm/boot/dts/kirkwood-dockstar.dts
+@@ -78,18 +78,22 @@
+
+ partition@0 {
+ label = "u-boot";
+- reg = <0x0000000 0x100000>;
+- read-only;
++ reg = <0x0000000 0xe0000>;
++ };
++
++ partition@e0000 {
++ label = "u-boot environment";
++ reg = <0xe0000 0x100000>;
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x400000>;
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
+ };
+
+- partition@500000 {
+- label = "data";
+- reg = <0x0500000 0xfb00000>;
++ partition@200000 {
++ label = "ubi";
++ reg = <0x200000 0xfe00000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-4.14/104-ea3500.patch b/target/linux/kirkwood/patches-4.14/104-ea3500.patch
new file mode 100644
index 0000000000..73bb252a79
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/104-ea3500.patch
@@ -0,0 +1,258 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -250,6 +250,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
+ kirkwood-linkstation-lswsxl.dtb \
+ kirkwood-linkstation-lswvl.dtb \
+ kirkwood-linkstation-lswxl.dtb \
++ kirkwood-linksys-audi.dtb \
+ kirkwood-linksys-viper.dtb \
+ kirkwood-lschlv2.dtb \
+ kirkwood-lsxhl.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-linksys-audi.dts
+@@ -0,0 +1,245 @@
++/*
++ * kirkwood-linksys-audi.dts - Device Tree file for Linksys EA3500
++ *
++ * (c) 2013 Jonas Gorski <jogo@openwrt.org>
++ * (c) 2013 Deutsche Telekom Innovation Laboratories
++ * (c) 2014 Luka Perkov <luka@openwrt.org>
++ * (c) 2014 Dan Walters <dan@walters.io>
++ *
++ * This file is licensed under the terms of the GNU General Public
++ * License version 2. This program is licensed "as is" without any
++ * warranty of any kind, whether express or implied.
++ */
++
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6282.dtsi"
++
++/ {
++ model = "Linksys Audi (EA3500)";
++ compatible = "linksys,audi", "marvell,kirkwood-88f6282", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x4000000>;
++ };
++
++ aliases {
++ serial0 = &uart0;
++ };
++
++ chosen {
++ stdout-path = "serial0:115200n8";
++ };
++
++ gpio_keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = < &pmx_btn_wps &pmx_btn_reset >;
++ pinctrl-names = "default";
++
++ wps {
++ label = "WPS Button";
++ linux,code = <KEY_WPS_BUTTON>;
++ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
++ };
++
++ reset {
++ label = "Reset Button";
++ linux,code = <KEY_RESTART>;
++ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = < &pmx_led_green_power >;
++ pinctrl-names = "default";
++
++ green-power {
++ label = "audi:green:power";
++ gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
++ };
++ };
++
++ mvsw61xx {
++ compatible = "marvell,88e6171";
++ status = "okay";
++ reg = <0x10>;
++
++ mii-bus = <&mdio>;
++ cpu-port-0 = <5>;
++ cpu-port-1 = <6>;
++ is-indirect;
++ };
++
++ dsa {
++ compatible = "marvell,dsa";
++ #address-cells = <2>;
++ #size-cells = <0>;
++
++ dsa,ethernet = <&eth0port>;
++ dsa,mii-bus = <&mdio>;
++
++ switch@16,0 {
++ #address-cells = <1>;
++ #size-cells = <0>;
++ reg = <16 0>; /* MDIO address 16, switch 0 in tree */
++
++ port@0 {
++ reg = <0>;
++ label = "ethernet1";
++ };
++
++ port@1 {
++ reg = <1>;
++ label = "ethernet2";
++ };
++
++ port@2 {
++ reg = <2>;
++ label = "ethernet3";
++ };
++
++ port@3 {
++ reg = <3>;
++ label = "ethernet4";
++ };
++
++ port@4 {
++ reg = <4>;
++ label = "internet";
++ };
++
++ port@5 {
++ reg = <5>;
++ label = "cpu";
++ };
++ };
++ };
++};
++
++&pinctrl {
++ pmx_led_green_power: pmx-led-green-power {
++ marvell,pins = "mpp7";
++ marvell,function = "gpo";
++ };
++ pmx_btn_wps: pmx-btn-wps {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ pmx_btn_reset: pmx-btn-reset {
++ marvell,pins = "mpp48";
++ marvell,function = "gpio";
++ };
++};
++
++&nand {
++ status = "okay";
++ pinctrl-0 = <&pmx_nand>;
++ pinctrl-names = "default";
++
++ partitions {
++ compatible = "fixed-partitions";
++ #address-cells = <1>;
++ #size-cells = <1>;
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0 0x80000>;
++ read-only;
++ };
++
++ partition@80000 {
++ label = "u_env";
++ reg = <0x80000 0x4000>;
++ };
++
++ partition@84000 {
++ label = "s_env";
++ reg = <0x84000 0x4000>;
++ };
++
++ partition@200000 {
++ label = "kernel1";
++ reg = <0x200000 0x290000>;
++ };
++
++ partition@490000 {
++ label = "rootfs1";
++ reg = <0x490000 0x1170000>;
++ };
++
++ partition@1600000 {
++ label = "kernel2";
++ reg = <0x1600000 0x290000>;
++ };
++
++ partition@1890000 {
++ label = "rootfs2";
++ reg = <0x1890000 0x1170000>;
++ };
++
++ partition@2a00000 {
++ label = "syscfg";
++ reg = <0x2a00000 0x1600000>;
++ };
++
++ partition@88000 {
++ label = "unused";
++ reg = <0x88000 0x178000>;
++ };
++
++ };
++};
++
++&pciec {
++ status = "okay";
++};
++
++&pcie0 {
++ status = "okay";
++};
++
++&pcie1 {
++ status = "okay";
++};
++
++&mdio {
++ status = "okay";
++};
++
++&uart0 {
++ status = "okay";
++};
++
++/* eth0 is connected to a Marvell 88E6171 switch, without a PHY. So set
++ * fixed speed and duplex.
++ */
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
++};
++
++/* eth1 is connected to the switch at port 6. However DSA only supports a
++ * single CPU port. Upstream uses DSA so they disable this port to avoid confusion.
++ */
++&eth1 {
++ status = "okay";
++ ethernet1-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
++};
++
++/* There is no battery on the board, so the RTC does not keep
++ * time when there is no power, making it useless.
++ */
++&rtc {
++ status = "disabled";
++};
diff --git a/target/linux/kirkwood/patches-4.14/105-ea4500.patch b/target/linux/kirkwood/patches-4.14/105-ea4500.patch
new file mode 100644
index 0000000000..6cc3de221b
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/105-ea4500.patch
@@ -0,0 +1,121 @@
+--- a/arch/arm/boot/dts/kirkwood-linksys-viper.dts
++++ b/arch/arm/boot/dts/kirkwood-linksys-viper.dts
+@@ -69,9 +69,18 @@
+ };
+ };
+
+- dsa {
+- status = "disabled";
++ mvsw61xx {
++ compatible = "marvell,88e6171";
++ status = "okay";
++ reg = <0x10>;
++
++ mii-bus = <&mdio>;
++ cpu-port-0 = <5>;
++ cpu-port-1 = <6>;
++ is-indirect;
++ };
+
++ dsa {
+ compatible = "marvell,dsa";
+ #address-cells = <2>;
+ #size-cells = <0>;
+@@ -163,22 +172,22 @@
+ };
+
+ partition@200000 {
+- label = "kernel";
++ label = "kernel1";
+ reg = <0x200000 0x2A0000>;
+ };
+
+ partition@4A0000 {
+- label = "rootfs";
++ label = "rootfs1";
+ reg = <0x4A0000 0x1760000>;
+ };
+
+ partition@1C00000 {
+- label = "alt_kernel";
++ label = "kernel2";
+ reg = <0x1C00000 0x2A0000>;
+ };
+
+ partition@1EA0000 {
+- label = "alt_rootfs";
++ label = "rootfs2";
+ reg = <0x1EA0000 0x1760000>;
+ };
+
+@@ -209,53 +218,6 @@
+
+ &mdio {
+ status = "okay";
+-
+- switch@10 {
+- compatible = "marvell,mv88e6085";
+- #address-cells = <1>;
+- #size-cells = <0>;
+- reg = <16>;
+-
+- ports {
+- #address-cells = <1>;
+- #size-cells = <0>;
+-
+- port@0 {
+- reg = <0>;
+- label = "ethernet1";
+- };
+-
+- port@1 {
+- reg = <1>;
+- label = "ethernet2";
+- };
+-
+- port@2 {
+- reg = <2>;
+- label = "ethernet3";
+- };
+-
+- port@3 {
+- reg = <3>;
+- label = "ethernet4";
+- };
+-
+- port@4 {
+- reg = <4>;
+- label = "internet";
+- };
+-
+- port@5 {
+- reg = <5>;
+- label = "cpu";
+- ethernet = <&eth0port>;
+- fixed-link {
+- speed = <1000>;
+- full-duplex;
+- };
+- };
+- };
+- };
+ };
+
+ &uart0 {
+@@ -274,10 +236,14 @@
+ };
+
+ /* eth1 is connected to the switch at port 6. However DSA only supports a
+- * single CPU port. So leave this port disabled to avoid confusion.
++ * single CPU port. Upstream uses DSA so they disable this port to avoid confusion.
+ */
+ &eth1 {
+- status = "disabled";
++ status = "okay";
++ ethernet1-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
+ };
+
+ /* There is no battery on the board, so the RTC does not keep
diff --git a/target/linux/kirkwood/patches-4.14/105-goflexhome.patch b/target/linux/kirkwood/patches-4.14/105-goflexhome.patch
new file mode 100644
index 0000000000..8270613ea0
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/105-goflexhome.patch
@@ -0,0 +1,130 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -237,6 +237,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
+ kirkwood-ds411.dtb \
+ kirkwood-ds411j.dtb \
+ kirkwood-ds411slim.dtb \
++ kirkwood-goflexhome.dtb \
+ kirkwood-goflexnet.dtb \
+ kirkwood-guruplug-server-plus.dtb \
+ kirkwood-ib62x0.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
+@@ -0,0 +1,117 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "Seagate GoFlex Home";
++ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x8000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
++ stdout-path = &uart0;
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_usb_power_enable: pmx-usb-power-enable {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_white: pmx-led-white {
++ marvell,pins = "mpp40";
++ marvell,function = "gpio";
++ };
++ pmx_led_green: pmx-led_green {
++ marvell,pins = "mpp46";
++ marvell,function = "gpio";
++ };
++ pmx_led_orange: pmx-led-orange {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ };
++ serial@12000 {
++ status = "ok";
++ };
++
++ sata@80000 {
++ status = "okay";
++ nr-ports = <2>;
++ };
++
++ };
++ gpio-leds {
++ compatible = "gpio-leds";
++
++ health {
++ label = "status:green:health";
++ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "default-on";
++ };
++ fault {
++ label = "status:orange:fault";
++ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
++ };
++ misc {
++ label = "status:white:misc";
++ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "disk-activity";
++ };
++ };
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_usb_power_enable>;
++ pinctrl-names = "default";
++
++ usb_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ regulator-always-on;
++ regulator-boot-on;
++ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
++
++&nand {
++ chip-delay = <40>;
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x100000>;
++ read-only;
++ };
++
++ partition@100000 {
++ label = "ubi";
++ reg = <0x100000 0x0ff00000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ reg = <0>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};
diff --git a/target/linux/kirkwood/patches-4.14/106-goflexnet.patch b/target/linux/kirkwood/patches-4.14/106-goflexnet.patch
new file mode 100644
index 0000000000..b22176880b
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/106-goflexnet.patch
@@ -0,0 +1,23 @@
+--- a/arch/arm/boot/dts/kirkwood-goflexnet.dts
++++ b/arch/arm/boot/dts/kirkwood-goflexnet.dts
+@@ -159,18 +159,8 @@
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x400000>;
+- };
+-
+- partition@500000 {
+- label = "pogoplug";
+- reg = <0x0500000 0x2000000>;
+- };
+-
+- partition@2500000 {
+- label = "root";
+- reg = <0x02500000 0xd800000>;
++ label = "ubi";
++ reg = <0x0100000 0x0ff00000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-4.14/107-01-zyxel-nsa3x0-common-nand-partitions.patch b/target/linux/kirkwood/patches-4.14/107-01-zyxel-nsa3x0-common-nand-partitions.patch
new file mode 100644
index 0000000000..df654033fd
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/107-01-zyxel-nsa3x0-common-nand-partitions.patch
@@ -0,0 +1,48 @@
+--- a/arch/arm/boot/dts/kirkwood-nsa3x0-common.dtsi
++++ b/arch/arm/boot/dts/kirkwood-nsa3x0-common.dtsi
+@@ -112,40 +112,16 @@
+
+ partition@0 {
+ label = "uboot";
+- reg = <0x0000000 0x0100000>;
++ reg = <0x0000000 0x00c0000>;
+ read-only;
+ };
+ partition@100000 {
+ label = "uboot_env";
+- reg = <0x0100000 0x0080000>;
++ reg = <0x00c0000 0x0080000>;
+ };
+- partition@180000 {
+- label = "key_store";
+- reg = <0x0180000 0x0080000>;
+- };
+- partition@200000 {
+- label = "info";
+- reg = <0x0200000 0x0080000>;
+- };
+- partition@280000 {
+- label = "etc";
+- reg = <0x0280000 0x0a00000>;
+- };
+- partition@c80000 {
+- label = "kernel_1";
+- reg = <0x0c80000 0x0a00000>;
+- };
+- partition@1680000 {
+- label = "rootfs1";
+- reg = <0x1680000 0x2fc0000>;
+- };
+- partition@4640000 {
+- label = "kernel_2";
+- reg = <0x4640000 0x0a00000>;
+- };
+- partition@5040000 {
+- label = "rootfs2";
+- reg = <0x5040000 0x2fc0000>;
++ partition@140000 {
++ label = "ubi";
++ reg = <0x0140000 0x7ec0000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-4.14/107-02-nsa310b.patch b/target/linux/kirkwood/patches-4.14/107-02-nsa310b.patch
new file mode 100644
index 0000000000..eefd78abdb
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/107-02-nsa310b.patch
@@ -0,0 +1,147 @@
+kirkwood: add nsa310b dtb, a zyxel nsa310 variant
+
+add support to a nsa310 variant with red/green usb led
+and lm85 temp/fan controller
+
+Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
+
+NOTE: this patch can be upstreamed as-is, LEDE-specific
+ nand partitions are set in another patch
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -268,6 +268,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
+ kirkwood-ns2mini.dtb \
+ kirkwood-nsa310.dtb \
+ kirkwood-nsa310a.dtb \
++ kirkwood-nsa310b.dtb \
+ kirkwood-nsa320.dtb \
+ kirkwood-nsa325.dtb \
+ kirkwood-openblocks_a6.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-nsa310b.dts
+@@ -0,0 +1,124 @@
++/dts-v1/;
++
++#include "kirkwood-nsa3x0-common.dtsi"
++
++/*
++ * There are at least two different NSA310 designs. This variant has
++ * a red/green USB Led (same as nsa310) and a lm85 temp/fan controller.
++ */
++
++/ {
++ model = "ZyXEL NSA310b";
++ compatible = "zyxel,nsa310b", "zyxel,nsa310", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x10000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200";
++ stdout-path = &uart0;
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pinctrl-names = "default";
++
++ pmx_led_esata_green: pmx-led-esata-green {
++ marvell,pins = "mpp12";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_esata_red: pmx-led-esata-red {
++ marvell,pins = "mpp13";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_usb_green: pmx-led-usb-green {
++ marvell,pins = "mpp15";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_usb_red: pmx-led-usb-red {
++ marvell,pins = "mpp16";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_sys_green: pmx-led-sys-green {
++ marvell,pins = "mpp28";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_sys_red: pmx-led-sys-red {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_hdd_green: pmx-led-hdd-green {
++ marvell,pins = "mpp41";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_hdd_red: pmx-led-hdd-red {
++ marvell,pins = "mpp42";
++ marvell,function = "gpio";
++ };
++
++ };
++
++ i2c@11000 {
++ status = "okay";
++
++ lm85: lm85@2e {
++ compatible = "national,lm85";
++ reg = <0x2e>;
++ };
++ };
++ };
++
++ gpio-leds {
++ compatible = "gpio-leds";
++
++ green-sys {
++ label = "nsa310:green:sys";
++ gpios = <&gpio0 28 GPIO_ACTIVE_HIGH>;
++ };
++ red-sys {
++ label = "nsa310:red:sys";
++ gpios = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ green-hdd {
++ label = "nsa310:green:hdd";
++ gpios = <&gpio1 9 GPIO_ACTIVE_HIGH>;
++ };
++ red-hdd {
++ label = "nsa310:red:hdd";
++ gpios = <&gpio1 10 GPIO_ACTIVE_HIGH>;
++ };
++ green-esata {
++ label = "nsa310:green:esata";
++ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
++ };
++ red-esata {
++ label = "nsa310:red:esata";
++ gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
++ };
++ green-usb {
++ label = "nsa310:green:usb";
++ gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
++ };
++ red-usb {
++ label = "nsa310:red:usb";
++ gpios = <&gpio0 16 GPIO_ACTIVE_HIGH>;
++ };
++ green-copy {
++ label = "nsa310:green:copy";
++ gpios = <&gpio1 7 GPIO_ACTIVE_HIGH>;
++ };
++ red-copy {
++ label = "nsa310:red:copy";
++ gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
diff --git a/target/linux/kirkwood/patches-4.14/108-on100.patch b/target/linux/kirkwood/patches-4.14/108-on100.patch
new file mode 100644
index 0000000000..7856277e40
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/108-on100.patch
@@ -0,0 +1,173 @@
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-on100.dts
+@@ -0,0 +1,160 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6282.dtsi"
++
++/ {
++ model = "Cisco Systems ON100";
++ compatible = "cisco,on100", "marvell,kirkwood-88f6282", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x20000000>;
++ };
++
++ aliases {
++ serial0 = &uart0;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk";
++ stdout-path = "serial0:115200n8";
++ };
++
++ gpio_keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_btn_reset>;
++ pinctrl-names = "default";
++
++ button@1 {
++ label = "Reset Button";
++ linux,code = <KEY_RESTART>;
++ gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = < &pmx_led_health_r &pmx_led_health_g >;
++ pinctrl-names = "default";
++
++ health-g {
++ label = "on100:green:health";
++ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
++ };
++
++ health-r {
++ label = "on100:red:health";
++ gpios = <&gpio1 13 GPIO_ACTIVE_LOW>;
++ };
++
++ health2-g {
++ label = "on100:green:health2";
++ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
++ };
++
++ health2-r {
++ label = "on100:red:health2";
++ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
++ };
++ };
++};
++
++&eth0 {
++ status = "okay";
++
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ phy-connection-type = "rgmii-id";
++ };
++};
++
++&eth1 {
++ status = "okay";
++
++ ethernet1-port@0 {
++ phy-handle = <&ethphy1>;
++ phy-connection-type = "rgmii-id";
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ /* Marvell 88E1121R */
++ compatible = "ethernet-phy-id0141.0cb0",
++ "ethernet-phy-ieee802.3-c22";
++ reg = <0>;
++ };
++
++ ethphy1: ethernet-phy@1 {
++ /* Marvell 88E1121R */
++ compatible = "ethernet-phy-id0141.0cb0",
++ "ethernet-phy-ieee802.3-c22";
++ reg = <1>;
++ };
++};
++
++&nand {
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x00000000 0x000a0000>;
++ read-only;
++ };
++
++ partition@a0000 {
++ label = "u-boot environment";
++ reg = <0x000a0000 0x00020000>;
++ read-only;
++ };
++
++ partition@c0000 {
++ label = "kernel";
++ reg = <0x000c0000 0x00540000>;
++ };
++
++ partition@600000 {
++ label = "ubi";
++ reg = <0x00600000 0x1fa00000>;
++ };
++};
++
++&pinctrl {
++ pmx_led_health_r: pmx-led-health-r {
++ marvell,pins = "mpp45";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_health_g: pmx-led-health-g {
++ marvell,pins = "mpp44";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_health2_r: pmx-led-health2-r {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++
++ pmx_led_health2_g: pmx-led-health2-g {
++ marvell,pins = "mpp46";
++ marvell,function = "gpio";
++ };
++
++ pmx_btn_reset: pmx-led-reset {
++ marvell,pins = "mpp31";
++ marvell,function = "gpio";
++ };
++};
++
++&sdio {
++ status = "okay";
++};
++
++&uart0 {
++ status = "okay";
++};
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -271,6 +271,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
+ kirkwood-nsa310b.dtb \
+ kirkwood-nsa320.dtb \
+ kirkwood-nsa325.dtb \
++ kirkwood-on100.dtb \
+ kirkwood-openblocks_a6.dtb \
+ kirkwood-openblocks_a7.dtb \
+ kirkwood-openrd-base.dtb \
diff --git a/target/linux/kirkwood/patches-4.14/109-pogoplug_v4.patch b/target/linux/kirkwood/patches-4.14/109-pogoplug_v4.patch
new file mode 100644
index 0000000000..b4e53cd659
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/109-pogoplug_v4.patch
@@ -0,0 +1,59 @@
+--- a/arch/arm/boot/dts/kirkwood-pogoplug-series-4.dts
++++ b/arch/arm/boot/dts/kirkwood-pogoplug-series-4.dts
+@@ -24,6 +24,7 @@
+ };
+
+ chosen {
++ bootargs = "console=ttyS0,115200";
+ stdout-path = "uart0:115200n8";
+ };
+
+@@ -37,8 +38,8 @@
+ eject {
+ debounce_interval = <50>;
+ wakeup-source;
+- linux,code = <KEY_EJECTCD>;
+- label = "Eject Button";
++ linux,code = <KEY_RESTART>;
++ label = "Reset";
+ gpios = <&gpio0 29 GPIO_ACTIVE_LOW>;
+ };
+ };
+@@ -137,29 +138,19 @@
+ #size-cells = <1>;
+
+ partition@0 {
+- label = "u-boot";
+- reg = <0x00000000 0x200000>;
++ label = "uboot";
++ reg = <0x00000000 0x1c0000>;
+ read-only;
+ };
+
+- partition@200000 {
+- label = "uImage";
+- reg = <0x00200000 0x300000>;
+- };
+-
+- partition@500000 {
+- label = "uImage2";
+- reg = <0x00500000 0x300000>;
++ partition@1c0000 {
++ label = "uboot_env";
++ reg = <0x001c0000 0x40000>;
+ };
+
+- partition@800000 {
+- label = "failsafe";
+- reg = <0x00800000 0x800000>;
+- };
+-
+- partition@1000000 {
+- label = "root";
+- reg = <0x01000000 0x7000000>;
++ partition@200000 {
++ label = "ubi";
++ reg = <0x00200000 0x7e00000>;
+ };
+ };
+ };
diff --git a/target/linux/kirkwood/patches-4.14/200-disable-tso.patch b/target/linux/kirkwood/patches-4.14/200-disable-tso.patch
new file mode 100644
index 0000000000..4b0cbeaba2
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/200-disable-tso.patch
@@ -0,0 +1,35 @@
+From: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
+Subject: [PATCH] net: mv643xx_eth: Make TSO disabled by default
+
+Data corruption has been observed to be produced by TSO. For instance,
+accessing files on a NFS-server with TSO enabled results in different data
+transferred each time.
+
+This has been observed only on Kirkwood platforms, i.e. with the mv643xx_eth
+driver. Same tests on platforms using the mvneta ethernet driver have
+passed without errors.
+
+Make TSO disabled by default for now, until we can found a proper fix
+for the regression.
+
+Fixes: 3ae8f4e0b98 ('net: mv643xx_eth: Implement software TSO')
+Reported-by: Slawomir Gajzner <slawomir.gajzner <at> gmail.com>
+Reported-by: Julien D'Ascenzio <jdascenzio <at> yahoo.fr>
+Signed-off-by: Ezequiel Garcia <ezequiel.garcia <at> free-electrons.com>
+---
+--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
++++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
+@@ -3200,11 +3200,11 @@ static int mv643xx_eth_probe(struct plat
+ dev->watchdog_timeo = 2 * HZ;
+ dev->base_addr = 0;
+
+- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
++ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
+ dev->vlan_features = dev->features;
+
+ dev->features |= NETIF_F_RXCSUM;
+- dev->hw_features = dev->features;
++ dev->hw_features = dev->features | NETIF_F_TSO;
+
+ dev->priv_flags |= IFF_UNICAST_FLT;
+ dev->gso_max_segs = MV643XX_MAX_TSO_SEGS;
diff --git a/target/linux/kirkwood/patches-4.14/201-enable-sata-port-specific-led-triggers.patch b/target/linux/kirkwood/patches-4.14/201-enable-sata-port-specific-led-triggers.patch
new file mode 100644
index 0000000000..c1645367a4
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/201-enable-sata-port-specific-led-triggers.patch
@@ -0,0 +1,10 @@
+--- a/arch/arm/mach-mvebu/Kconfig
++++ b/arch/arm/mach-mvebu/Kconfig
+@@ -119,6 +119,7 @@ config MACH_DOVE
+ config MACH_KIRKWOOD
+ bool "Marvell Kirkwood boards"
+ depends on ARCH_MULTI_V5
++ select ARCH_WANT_LIBATA_LEDS
+ select CPU_FEROCEON
+ select GPIOLIB
+ select KIRKWOOD_CLK
diff --git a/target/linux/kirkwood/patches-4.14/202-linksys-find-active-root.patch b/target/linux/kirkwood/patches-4.14/202-linksys-find-active-root.patch
new file mode 100644
index 0000000000..860d7b0728
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.14/202-linksys-find-active-root.patch
@@ -0,0 +1,62 @@
+The WRT1900AC among other Linksys routers uses a dual-firmware layout.
+Dynamically rename the active partition to "ubi".
+
+Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
+---
+--- a/drivers/mtd/ofpart.c
++++ b/drivers/mtd/ofpart.c
+@@ -25,6 +25,8 @@ static bool node_has_compatible(struct d
+ return of_get_property(pp, "compatible", NULL);
+ }
+
++static int mangled_rootblock;
++
+ static int parse_fixed_partitions(struct mtd_info *master,
+ const struct mtd_partition **pparts,
+ struct mtd_part_parser_data *data)
+@@ -32,6 +34,7 @@ static int parse_fixed_partitions(struct
+ struct mtd_partition *parts;
+ struct device_node *mtd_node;
+ struct device_node *ofpart_node;
++ const char *owrtpart = "ubi";
+ const char *partname;
+ struct device_node *pp;
+ int nr_parts, i, ret = 0;
+@@ -110,9 +113,15 @@ static int parse_fixed_partitions(struct
+ parts[i].size = of_read_number(reg + a_cells, s_cells);
+ parts[i].of_node = pp;
+
+- partname = of_get_property(pp, "label", &len);
+- if (!partname)
+- partname = of_get_property(pp, "name", &len);
++ if (mangled_rootblock && (i == mangled_rootblock)) {
++ partname = owrtpart;
++ } else {
++ partname = of_get_property(pp, "label", &len);
++
++ if (!partname)
++ partname = of_get_property(pp, "name", &len);
++ }
++
+ parts[i].name = partname;
+
+ if (of_get_property(pp, "read-only", &len))
+@@ -219,6 +228,18 @@ static int __init ofpart_parser_init(voi
+ return 0;
+ }
+
++static int __init active_root(char *str)
++{
++ get_option(&str, &mangled_rootblock);
++
++ if (!mangled_rootblock)
++ return 1;
++
++ return 1;
++}
++
++__setup("mangled_rootblock=", active_root);
++
+ static void __exit ofpart_parser_exit(void)
+ {
+ deregister_mtd_parser(&ofpart_parser);