aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2017-02-06 11:40:52 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-11 21:16:28 +0100
commit4383c13aee8963ee93ca1950e7f0ea5a35309ab4 (patch)
tree08429fcda96d5beb22be21f7fa3380029155b0b7 /target/linux/kirkwood/image
parentadd1dd00813ccccfe5f1ee8e6bf04db7822b9fd5 (diff)
downloadupstream-4383c13aee8963ee93ca1950e7f0ea5a35309ab4.tar.gz
upstream-4383c13aee8963ee93ca1950e7f0ea5a35309ab4.tar.bz2
upstream-4383c13aee8963ee93ca1950e7f0ea5a35309ab4.zip
kirkwood: add ZyXEL NSA325 device
This patch add ZyXEL NSA325 2-Bay Media Server The ZyXEL NSA325 device is a Kirkwood based NAS: - SoC: Marvell 88F6702 1600Mhz - SDRAM memory: 512MB DDR2 400Mhz - Gigabit ethernet: Marvell Alaska - Flash memory: 128MB - 1 Power button - 1 Power LED (blue) - 5 Status LED (green/red) - 1 Copy/Sync button - 1 Reset button - 2 SATA II ports (internal) - 2 USB 2.0 ports (back) - 1 USB 3.0 port (front) - Fan (fixed speed) - hardware watchdog in a mcu Basically a bigger, more powerful version of NSA310, installation is the same as they share the same flash layout. A notable difference is that there is a hardware watchdog in a mcu on the board, which is disabled by default in the LEDE u-boot. The watchdog is also disabled with a GPIO activation through raw register change when kwbooting or it would reset the board before the new uboot was transferred. Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it> Signed-off-by: Felix Fietkau <nbd@nbd.name> [remove dead code]
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index ece7c1adf6..141505e002 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR:=0x8000
-TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0 nsa310b
+TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0 nsa310b nsa325
UBI_OPTS := -m 2048 -p 128KiB -s 512
UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
@@ -87,6 +87,13 @@ $(Device/dockstar)
DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
endef
+define Device/nsa325
+$(Device/dockstar)
+ DEVICE_TITLE := ZyXEL NSA325 (v1 and v2)
+ DEVICE_DTS := kirkwood-nsa325
+ DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+endef
+
define Device/pogo_e02
$(Device/dockstar)
DEVICE_TITLE := Cloud Engines Pogoplug E02