aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-11 14:03:46 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 14:04:18 +0100
commit3be4c6ca93ec41b8ae0d5bfd1f1ebf8f7d4dfbaf (patch)
tree5d777b158e28f8e3a2fe02264fcd115bc5ab4f23 /target/linux/kirkwood/image
parent4d8da82c29e9c2c1691d16977f41bfe27da69f17 (diff)
downloadupstream-3be4c6ca93ec41b8ae0d5bfd1f1ebf8f7d4dfbaf.tar.gz
upstream-3be4c6ca93ec41b8ae0d5bfd1f1ebf8f7d4dfbaf.tar.bz2
upstream-3be4c6ca93ec41b8ae0d5bfd1f1ebf8f7d4dfbaf.zip
kirkwood: only add UBI EOF markers for devices that need it
Fixes issues where the second-stage u-boot already uses UBI. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 2c4ad208f2..520430f2c2 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -28,7 +28,6 @@ define Device/Default
SUBPAGESIZE := 512
BLOCKSIZE := 128k
IMAGES := sysupgrade.tar
- UBINIZE_OPTS := -E 5
IMAGE/sysupgrade.tar := sysupgrade-tar
endef
@@ -60,6 +59,7 @@ define Device/linksys-audi
KERNEL_SIZE := 2624k
FILESYSTEMS := squashfs
IMAGES += factory.bin
+ UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
@@ -70,6 +70,7 @@ define Device/linksys-viper
KERNEL_SIZE := 2688k
FILESYSTEMS := squashfs
IMAGES += factory.bin
+ UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef