aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:15 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:27:12 +0100
commit6fe31abc5a466f533547d91aed6b747cd3c44efe (patch)
treeb24f3df0794666ef23cde91f4c48054453c8acd9 /target/linux/kirkwood/image
parentd0d8584b4187da38b484da3290fbb23ca472abad (diff)
downloadupstream-6fe31abc5a466f533547d91aed6b747cd3c44efe.tar.gz
upstream-6fe31abc5a466f533547d91aed6b747cd3c44efe.tar.bz2
upstream-6fe31abc5a466f533547d91aed6b747cd3c44efe.zip
kirkwood: exploit BOARD_NAME to set DEVICE_DTS and SUPPORTED_DEVICES
Due to the history of the target, all devices added before a certain point have the same device string in BOARD_NAME, DEVICE_DTS and added to SUPPORTED_DEVICES. Thus, we can set this one automatically for all devices where BOARD_NAME is specified, removing the explicit DEVICE_DTS and SUPPORTED_DEVICES addition there. For new devices, nothing has changed, and just DEVICE_DTS has to be set manually. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile22
1 files changed, 2 insertions, 20 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 7b59b69c1d..9c5681901c 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -12,6 +12,7 @@ KERNEL_LOADADDR:=0x8000
define Device/Default
PROFILES := Default
+ DEVICE_DTS = $$(if $$(BOARD_NAME),kirkwood-$$(BOARD_NAME),)
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
@@ -24,13 +25,12 @@ define Device/Default
IMAGES := sysupgrade.bin factory.bin
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.bin := append-ubi
- SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+ SUPPORTED_DEVICES = $(subst _,$(comma),$(1)) $$(BOARD_NAME)
endef
define Device/cisco_on100
DEVICE_VENDOR := Cisco Systems
DEVICE_MODEL := ON100
- DEVICE_DTS := kirkwood-on100
DEVICE_PACKAGES := kmod-i2c-mv64xxx
KERNEL_SIZE := 5376k
KERNEL_IN_UBI :=
@@ -43,9 +43,7 @@ TARGET_DEVICES += cisco_on100
define Device/cloudengines_pogoe02
DEVICE_VENDOR := Cloud Engines
DEVICE_MODEL := Pogoplug E02
- DEVICE_DTS := kirkwood-pogo_e02
BOARD_NAME := pogo_e02
- SUPPORTED_DEVICES += pogo_e02
endef
TARGET_DEVICES += cloudengines_pogoe02
@@ -60,9 +58,7 @@ TARGET_DEVICES += cloudengines_pogoplugv4
define Device/iom_iconnect-1.1
DEVICE_VENDOR := Iomega
DEVICE_MODEL := Iconnect
- DEVICE_DTS := kirkwood-iconnect
BOARD_NAME := iconnect
- SUPPORTED_DEVICES += iconnect
endef
TARGET_DEVICES += iom_iconnect-1.1
@@ -87,7 +83,6 @@ define Device/linksys_audi
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA3500 (Audi)
DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-basic kmod-gpio-button-hotplug
- DEVICE_DTS := kirkwood-linksys-audi
PAGESIZE := 512
SUBPAGESIZE := 256
BLOCKSIZE := 16KiB
@@ -96,7 +91,6 @@ define Device/linksys_audi
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
BOARD_NAME := linksys-audi
- SUPPORTED_DEVICES += linksys-audi
endef
TARGET_DEVICES += linksys_audi
@@ -104,56 +98,45 @@ define Device/linksys_viper
DEVICE_VENDOR := Linksys
DEVICE_MODEL := E4200v2 / EA4500 (Viper)
DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-basic kmod-gpio-button-hotplug
- DEVICE_DTS := kirkwood-linksys-viper
KERNEL_SIZE := 2688k
KERNEL_IN_UBI :=
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
BOARD_NAME := linksys-viper
- SUPPORTED_DEVICES += linksys-viper
endef
TARGET_DEVICES += linksys_viper
define Device/raidsonic_ib-nas62x0
DEVICE_VENDOR := RaidSonic
DEVICE_MODEL := ICY BOX IB-NAS62x0
- DEVICE_DTS := kirkwood-ib62x0
BOARD_NAME := ib62x0
- SUPPORTED_DEVICES += ib62x0
endef
TARGET_DEVICES += raidsonic_ib-nas62x0
define Device/seagate_dockstar
DEVICE_VENDOR := Seagate
DEVICE_MODEL := FreeAgent Dockstar
- DEVICE_DTS := kirkwood-dockstar
BOARD_NAME := dockstar
- SUPPORTED_DEVICES += dockstar
endef
TARGET_DEVICES += seagate_dockstar
define Device/seagate_goflexnet
DEVICE_VENDOR := Seagate
DEVICE_MODEL := GoFlexNet
- DEVICE_DTS := kirkwood-goflexnet
BOARD_NAME := goflexnet
- SUPPORTED_DEVICES += goflexnet
endef
TARGET_DEVICES += seagate_goflexnet
define Device/seagate_goflexhome
DEVICE_VENDOR := Seagate
DEVICE_MODEL := GoFlexHome
- DEVICE_DTS := kirkwood-goflexhome
BOARD_NAME := goflexhome
- SUPPORTED_DEVICES += goflexhome
endef
TARGET_DEVICES += seagate_goflexhome
define Device/zyxel_nsa310b
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NSA310b
- DEVICE_DTS := kirkwood-nsa310b
DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
BOARD_NAME := nsa310b
endef
@@ -163,7 +146,6 @@ define Device/zyxel_nsa325
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NSA325
DEVICE_VARIANT := v1/v2
- DEVICE_DTS := kirkwood-nsa325
DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
BOARD_NAME := nsa325
endef