aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image/Makefile
diff options
context:
space:
mode:
authorBERENYI Balazs <balazs@wee.hu>2021-01-02 18:49:42 +0000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-06 19:05:07 +0200
commit03d66d6b8fa6660a89648847a69d691a9a82d5b4 (patch)
tree80f9fe1c414bd11cff86bc48e31ae4052027fe82 /target/linux/kirkwood/image/Makefile
parenta509b80065b6680e3e007203084c147f77b6717f (diff)
downloadupstream-03d66d6b8fa6660a89648847a69d691a9a82d5b4.tar.gz
upstream-03d66d6b8fa6660a89648847a69d691a9a82d5b4.tar.bz2
upstream-03d66d6b8fa6660a89648847a69d691a9a82d5b4.zip
kirkwood: Add support for Sheevaplug
Globalscale SheevaPlug: * Marvell Kirkwood 88F6281 * 512 MB SDRAM * 512 MB Flash * Gigabit Network * USB 2.0 * SD slot * Serial console The device is supported in mainline uboot/linux the commit adds only some openwrt config for building an image. Installation: 1 - Update uboot: setenv ipaddr '192.168.0.111' setenv serverip '192.168.0.1' tftpboot u-boot.kwb nand erase 0x0 0x100000 nand write 0x800000 0x0 0x100000 reset 2 - Install OpenWRT: setenv ethaddr 00:50:43:01:xx:xx saveenv setenv ipaddr '192.168.0.111' setenv serverip '192.168.0.1' tftpboot openwrt-kirkwood-globalscale_sheevaplug-squashfs-factory.bin nand erase.part ubi nand write 0x800000 ubi 0x600000 reset Signed-off-by: BERENYI Balazs <balazs@wee.hu> Reviewed-by: Pawel Dembicki <paweldembicki@gmail.com> [add vendor name for uboot-kirkwood, merge patches, copy to 5.10, add AUTORELEASE for uboot-kirkwood, refresh patches] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood/image/Makefile')
-rw-r--r--target/linux/kirkwood/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index e06eb050ef..c2c5bcab8f 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -67,6 +67,13 @@ define Device/cloudengines_pogoplugv4
endef
TARGET_DEVICES += cloudengines_pogoplugv4
+define Device/globalscale_sheevaplug
+ DEVICE_VENDOR := Globalscale
+ DEVICE_MODEL := Sheevaplug
+ DEVICE_PACKAGES := kmod-mvsdio
+endef
+TARGET_DEVICES += globalscale_sheevaplug
+
define Device/iom_iconnect-1.1
DEVICE_VENDOR := Iomega
DEVICE_MODEL := Iconnect