aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit704e2ed39d4e157d0c24d4dc3a3078cbacc6505c (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/ixp4xx
parent5431c1983b51e4f69db63f5d5c94b2ed157e5374 (diff)
downloadupstream-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.gz
upstream-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.bz2
upstream-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/Makefile1
-rw-r--r--target/linux/ixp4xx/image/Makefile4
2 files changed, 1 insertions, 4 deletions
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 58f3ec811e..7cdf7cf665 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -18,5 +18,6 @@ LINUX_VERSION:=3.3.8
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+KERNELNAME:="zImage"
$(eval $(call BuildTarget))
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 30e5b12498..564cafcf34 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -31,10 +31,6 @@ define Image/Build/Freecom
rm -f $(TARGET_DIR)/zImage
endef
-define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
-endef
-
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh