aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/ixp4xx/profiles
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/ixp4xx/profiles')
-rw-r--r--target/linux/ixp4xx/profiles/100-Default.mk17
-rw-r--r--target/linux/ixp4xx/profiles/200-NSLU2.mk20
-rw-r--r--target/linux/ixp4xx/profiles/300-NAS100d.mk21
-rw-r--r--target/linux/ixp4xx/profiles/400-DSMG600RevA.mk21
-rw-r--r--target/linux/ixp4xx/profiles/500-FSG3.mk20
5 files changed, 99 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/profiles/100-Default.mk b/target/linux/ixp4xx/profiles/100-Default.mk
new file mode 100644
index 0000000000..104268bd8e
--- /dev/null
+++ b/target/linux/ixp4xx/profiles/100-Default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Default/Description
+ Default IXP4xx Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/ixp4xx/profiles/200-NSLU2.mk b/target/linux/ixp4xx/profiles/200-NSLU2.mk
new file mode 100644
index 0000000000..a4e1a30858
--- /dev/null
+++ b/target/linux/ixp4xx/profiles/200-NSLU2.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NSLU2
+ NAME:=Linksys NSLU2
+ PACKAGES:=kmod-ixp4xx-npe \
+ kmod-scsi-core \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NSLU2/Description
+ Package set optimized for the Linksys NSLU2
+endef
+$(eval $(call Profile,NSLU2))
+
diff --git a/target/linux/ixp4xx/profiles/300-NAS100d.mk b/target/linux/ixp4xx/profiles/300-NAS100d.mk
new file mode 100644
index 0000000000..f72128ecdc
--- /dev/null
+++ b/target/linux/ixp4xx/profiles/300-NAS100d.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NAS100d
+ NAME:=Iomega NAS 100d
+ PACKAGES:=kmod-ixp4xx-npe \
+ kmod-madwifi wireless-tools \
+ kmod-scsi-core kmod-libata kmod-pata-artop \
+ kmod-usb-core kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NAS100d/Description
+ Package set optimized for the Iomega NAS 100d
+endef
+$(eval $(call Profile,NAS100d))
+
diff --git a/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk
new file mode 100644
index 0000000000..4eec1c5c6c
--- /dev/null
+++ b/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DSMG600RevA
+ NAME:=DSM-G600 Rev A
+ PACKAGES:=kmod-via-velocity \
+ kmod-madwifi wireless-tools \
+ kmod-scsi-core kmod-libata kmod-pata-artop \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/DSMG600RevA/Description
+ Package set optimized for the DSM-G600 Rev A
+endef
+$(eval $(call Profile,DSMG600RevA))
+
diff --git a/target/linux/ixp4xx/profiles/500-FSG3.mk b/target/linux/ixp4xx/profiles/500-FSG3.mk
new file mode 100644
index 0000000000..d7d6a2ef75
--- /dev/null
+++ b/target/linux/ixp4xx/profiles/500-FSG3.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+ NAME:=Freecom FSG-3
+ PACKAGES:= \
+ kmod-madwifi wireless-tools \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2
+endef
+
+define Profile/FSG3/Description
+ Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+