aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/modules.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-06-12 01:14:25 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-06-12 01:18:52 +0200
commit000d400baa0af2e42c9a462e42df7dc9abde1ec7 (patch)
treea11c2dd570e8f02c4a141f135fc8db1e1d391ef2 /target/linux/ixp4xx/modules.mk
parentc4e727f01cc40bd57274d0b885b0f75cde9c4683 (diff)
downloadupstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.tar.gz
upstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.tar.bz2
upstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.zip
kernel: drop everything not on kernel version 4.14
* Remove testing patches for kernel version 4.19 * remove targets ar7, ixp4xx, orion Those targets are still on kernel 4.9, patches for 4.14 were not ready in time. They may be readded once people prepare and test patches for kernel 4.14. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/ixp4xx/modules.mk')
-rw-r--r--target/linux/ixp4xx/modules.mk74
1 files changed, 0 insertions, 74 deletions
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
deleted file mode 100644
index 2d6446c05b..0000000000
--- a/target/linux/ixp4xx/modules.mk
+++ /dev/null
@@ -1,74 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define KernelPackage/ata-ixp4xx-cf
- SUBMENU:=$(BLOCK_MENU)
- TITLE:=IXP4XX Compact Flash support
- DEPENDS:=@TARGET_ixp4xx
- KCONFIG:=CONFIG_PATA_IXP4XX_CF
- FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.ko
- AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-ixp4xx-cf/description
- IXP4XX Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-ixp4xx-cf))
-
-
-define KernelPackage/ixp4xx-beeper
- SUBMENU:=$(OTHER_MENU)
- TITLE:=IXP4XX Beeper support
- DEPENDS:=@TARGET_ixp4xx +kmod-input-core
- KCONFIG:= \
- CONFIG_INPUT_MISC=y \
- CONFIG_INPUT_IXP4XX_BEEPER
- FILES:=$(LINUX_DIR)/drivers/input/misc/ixp4xx-beeper.ko
- AUTOLOAD:=$(call AutoLoad,50,ixp4xx-beeper)
- $(call AddDepends/input)
-endef
-
-define KernelPackage/ixp4xx-beeper/description
- IXP4XX Beeper support
-endef
-
-$(eval $(call KernelPackage,ixp4xx-beeper))
-
-
-define KernelPackage/crypto-hw-ixp4xx
- TITLE:=Intel IXP4xx hardware crypto module
- DEPENDS:=@TARGET_ixp4xx
- KCONFIG:= \
- CONFIG_CRYPTO_DEV_IXP4XX
- FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
- AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
- $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
-endef
-
-define KernelPackage/crypto-hw-ixp4xx/description
- Kernel support for the Intel IXP4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-hw-ixp4xx))
-
-
-define KernelPackage/ixp4xx-eth
- SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=IXP4xxt Ethernet Adapter kernel support
- DEPENDS:=@TARGET_ixp4xx
- KCONFIG:=CONFIG_IXP4XX_ETH
- FILES:=$(LINUX_DIR)/drivers/net/ethernet/xscale/ixp4xx_eth.ko
- AUTOLOAD:=$(call AutoLoad,50,ixp4xx_eth)
-endef
-
-define KernelPackage/ixp4xx-eth/description
- Kernel modules for Intel IXP4xx Ethernet chipsets.
-endef
-
-$(eval $(call KernelPackage,ixp4xx-eth))