aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-12-28 21:00:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-12-28 21:00:01 +0000
commitefadab3747594aaf96e828e0909eb9525433c236 (patch)
treee21be89886adb2a81cbb726094e699cad23fcfe7 /target/linux/ixp4xx/image/Makefile
parent91c42459f5ef87731628fe1f57fca3d50ee6ab5e (diff)
downloadupstream-efadab3747594aaf96e828e0909eb9525433c236.tar.gz
upstream-efadab3747594aaf96e828e0909eb9525433c236.tar.bz2
upstream-efadab3747594aaf96e828e0909eb9525433c236.zip
* upgrade ixp4xx to 2.6.23.12 * upgrade to the new ethernet driver (temporary breaks Marvell switch support on Compex units) * handle NPE microcodes in a user friendly way - YAY for Intel for changing the license * add support for the Lanready AP1000 (used in for example the Ligowave LGO2AGN)
SVN-Revision: 10016
Diffstat (limited to 'target/linux/ixp4xx/image/Makefile')
-rw-r--r--target/linux/ixp4xx/image/Makefile31
1 files changed, 4 insertions, 27 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 167bd1d5fa..b23ebc3b11 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -7,43 +7,28 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
-
-ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
- define Require/npe-ucode
- [ -f $(DL_DIR)/$(UCODEFILE) ]
- endef
- define Build/Compile/npe
- $(MAKE) -C npe-ucode \
- BUILD_DIR="$(KDIR)" \
- TARGET="$(KDIR)" \
- compile
- endef
- define Image/Build/slug
+define Image/Build/slug
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+ -L $(KDIR)/apex-nslu2-armeb.bin \
-k $(BIN_DIR)/openwrt-nslu2-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
-p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+ -F -L $(KDIR)/apex-nslu2-armeb.bin \
-k $(BIN_DIR)/openwrt-nslu2-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
-p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
- endef
-endif
+endef
define Build/Compile
$(MAKE) -C apex \
BUILD_DIR="$(KDIR)" \
TARGET="$(KDIR)" \
compile
- $(call Build/Compile/npe)
endef
define Build/Clean
$(MAKE) -C apex clean
- $(MAKE) -C npe-ucode clean
endef
define Image/Prepare
@@ -52,7 +37,6 @@ endef
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
-# $(shell BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh)
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
endef
@@ -76,10 +60,3 @@ define Image/Build/squashfs
endef
$(eval $(call BuildImage))
-
-$(eval $(call Require,npe-ucode, \
- You must manually download $(UCODEFILE) from \\\
- http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
- and put it in $(DL_DIR). \\\
- You will need to agree to the Intel Public License to do so - please do read it! \
-))