aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:30 +0000
commit0cb0c1a257f52266056306e0b8bcb5fb27bdf989 (patch)
tree1fc64ae50c1bd8cf17a92ef5aacf54778da1ac2a /target/linux/ixp4xx/image/Makefile
parent9493f9c19ed2c7d407dcd70e72934c00e3b5849a (diff)
downloadupstream-0cb0c1a257f52266056306e0b8bcb5fb27bdf989.tar.gz
upstream-0cb0c1a257f52266056306e0b8bcb5fb27bdf989.tar.bz2
upstream-0cb0c1a257f52266056306e0b8bcb5fb27bdf989.zip
ixp4xx: make apex optional, clean up the makefile - fixes spurious recompilation issues
SVN-Revision: 15115
Diffstat (limited to 'target/linux/ixp4xx/image/Makefile')
-rw-r--r--target/linux/ixp4xx/image/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 53d2ef0f63..82f2e96d58 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -7,18 +7,20 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Image/Build/Linksys
+ifdef CONFIG_PACKAGE_apex
+ define Image/Build/Linksys
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(BIN_DIR)/apex-$(2)-armeb.bin \
+ -L $(BIN_DIR)/apex/apex-$(2)-armeb.bin \
-k $(BIN_DIR)/openwrt-$(2)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
-p -o $(BIN_DIR)/openwrt-$(2)-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -F -L $(BIN_DIR)/apex-$(2)-16mb-armeb.bin \
+ -F -L $(BIN_DIR)/apex/apex-$(2)-16mb-armeb.bin \
-k $(BIN_DIR)/openwrt-$(2)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
-p -o $(BIN_DIR)/openwrt-$(2)-$(1)-16mb.bin
-endef
+ endef
+endif
define Image/Build/Freecom
$(INSTALL_DIR) $(TARGET_DIR)/boot
@@ -30,18 +32,6 @@ define Image/Build/Freecom
$(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
endef
-define Build/Compile
- mkdir -p $(BIN_DIR)
- $(MAKE) -C apex \
- BUILD_DIR="$(KDIR)" \
- TARGET="$(BIN_DIR)" \
- compile
-endef
-
-define Build/Clean
- $(MAKE) -C apex clean
-endef
-
define Image/Prepare
cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
endef