aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-01-29 20:07:41 +0000
committerJohn Crispin <blogic@openwrt.org>2008-01-29 20:07:41 +0000
commitcf1b94030f54f78e5be8299635d500e9526d470a (patch)
tree2288306cc8d171658f2c458b83053d471e08a1de /target/linux/ixp4xx/generic
parentc13871984f708ce2eddb102c376e27261a96709d (diff)
downloadupstream-cf1b94030f54f78e5be8299635d500e9526d470a.tar.gz
upstream-cf1b94030f54f78e5be8299635d500e9526d470a.tar.bz2
upstream-cf1b94030f54f78e5be8299635d500e9526d470a.zip
added new ixp4xx target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx/generic')
-rw-r--r--target/linux/ixp4xx/generic/profiles/500-WifiAP.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk b/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk
new file mode 100644
index 0000000000..cbbca80627
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WifiAP
+ NAME:=WifiAP
+ PACKAGES:=kmod-madwifi wireless-tools \
+ kmod-scsi-core \
+ kmod-ata-core kmod-ata-artop \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3 kmod-fs-vfat gpioctl openslp hostapd wpa-supplicant
+endef
+
+define Profile/WifiAP/Description
+ Full featured image for flash based ixp4xx devices used as industrial APs
+endef
+$(eval $(call Profile,WifiAP))
+