aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorBrian Norris <computersforpeace@gmail.com>2023-01-12 21:32:20 -0800
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-21 01:02:25 +0100
commit69d1b289b02a4a01bf0801f1000d59978fe5ecfe (patch)
treed8cb421f64662d5b30340b969f0bdc5cccd47ab1 /target/linux/ipq806x
parentc20915e8414c02cff24b9938944c63862176d2c2 (diff)
downloadupstream-69d1b289b02a4a01bf0801f1000d59978fe5ecfe.tar.gz
upstream-69d1b289b02a4a01bf0801f1000d59978fe5ecfe.tar.bz2
upstream-69d1b289b02a4a01bf0801f1000d59978fe5ecfe.zip
ipq806x: Add kmod-sound-soc-ipq8064-storm
For IPQ8064 systems based off the "Google Storm" reference platform, such as the TP-Link OnHub. Signed-off-by: Brian Norris <computersforpeace@gmail.com>
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/modules.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
index 605504b0c3..a2b844d0f0 100644
--- a/target/linux/ipq806x/modules.mk
+++ b/target/linux/ipq806x/modules.mk
@@ -14,3 +14,32 @@ define KernelPackage/phy-qcom-ipq806x-usb/description
endef
$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
+
+
+define KernelPackage/sound-soc-ipq8064-storm
+ TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
+ DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
+ KCONFIG:=\
+ CONFIG_IPQ_LCC_806X \
+ CONFIG_SND_SOC_QCOM \
+ CONFIG_SND_SOC_STORM \
+ CONFIG_SND_SOC_APQ8016_SBC=n \
+ CONFIG_SND_SOC_SC7180=n
+ FILES:=\
+ $(LINUX_DIR)/drivers/clk/qcom/lcc-ipq806x.ko \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
+ AUTOLOAD:=$(call AutoProbe,lcc-ipq806x \
+ snd-soc-max98357a snd-soc-lpass-ipq806x snd-soc-storm)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-ipq8064-storm/description
+ Provides sound support for the Google Storm platform, with a Qualcomm IPQ8064
+ SoC.
+endef
+
+$(eval $(call KernelPackage,sound-soc-ipq8064-storm))