aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-01-18 13:51:13 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-20 20:22:01 +0100
commitd8565a06dc01b55ed1018d571e655c122b9d2a33 (patch)
tree5f77a07078f849c8077162f38ac69a0af17d82a6 /target/linux/ipq806x
parent9ddfac80155b899d1d2eca97dfae5a9e551e9abc (diff)
downloadupstream-d8565a06dc01b55ed1018d571e655c122b9d2a33.tar.gz
upstream-d8565a06dc01b55ed1018d571e655c122b9d2a33.tar.bz2
upstream-d8565a06dc01b55ed1018d571e655c122b9d2a33.zip
kernel: bump 4.9 to 4.9.77
Refresh patches. Remove upstreamed patches: target/linux/generic/backport-4.9/023-2-smsc75xx-use-skb_cow_head-to-deal-with-cloned-skbs.patch target/linux/generic/backport-4.9/023-3-cx82310_eth-use-skb_cow_head-to-deal-with-cloned-skb.patch target/linux/generic/backport-4.9/023-4-sr9700-use-skb_cow_head-to-deal-with-cloned-skbs.patch target/linux/generic/backport-4.9/023-5-lan78xx-use-skb_cow_head-to-deal-with-cloned-skbs.patch CVEs completely or partially addressed: CVE-2017-5715 CVE-2017-5753 CVE-2017-17741 CVE-2017-1000410 Compile-tested: ar71xx Archer C7 v2 Run-tested: ar71xx Archer C7 v2 Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/patches-4.9/0032-phy-add-qcom-dwc3-phy.patch2
-rw-r--r--target/linux/ipq806x/patches-4.9/0074-ipq806x-usb-Control-USB-master-reset.patch14
-rw-r--r--target/linux/ipq806x/patches-4.9/830-usb-dwc3-register-qca-ipq4019-dwc3-in-dwc3-of-simple.patch2
3 files changed, 7 insertions, 11 deletions
diff --git a/target/linux/ipq806x/patches-4.9/0032-phy-add-qcom-dwc3-phy.patch b/target/linux/ipq806x/patches-4.9/0032-phy-add-qcom-dwc3-phy.patch
index bd777858e0..56535a3eec 100644
--- a/target/linux/ipq806x/patches-4.9/0032-phy-add-qcom-dwc3-phy.patch
+++ b/target/linux/ipq806x/patches-4.9/0032-phy-add-qcom-dwc3-phy.patch
@@ -32,7 +32,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
endmenu
--- a/drivers/phy/Makefile
+++ b/drivers/phy/Makefile
-@@ -60,3 +60,4 @@ obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
+@@ -60,3 +60,4 @@ obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-
obj-$(CONFIG_PHY_CYGNUS_PCIE) += phy-bcm-cygnus-pcie.o
obj-$(CONFIG_ARCH_TEGRA) += tegra/
obj-$(CONFIG_PHY_NS2_PCIE) += phy-bcm-ns2-pcie.o
diff --git a/target/linux/ipq806x/patches-4.9/0074-ipq806x-usb-Control-USB-master-reset.patch b/target/linux/ipq806x/patches-4.9/0074-ipq806x-usb-Control-USB-master-reset.patch
index d5ff868291..516c7c06ce 100644
--- a/target/linux/ipq806x/patches-4.9/0074-ipq806x-usb-Control-USB-master-reset.patch
+++ b/target/linux/ipq806x/patches-4.9/0074-ipq806x-usb-Control-USB-master-reset.patch
@@ -16,8 +16,6 @@ Signed-off-by: Vasudevan Murugesan <vmuruges@codeaurora.org>
(limited to 'drivers/usb/dwc3/dwc3-of-simple.c')
-diff --git a/drivers/usb/dwc3/dwc3-of-simple.c b/drivers/usb/dwc3/dwc3-of-simple.c
-index f9e92ef..49bf556 100644
--- a/drivers/usb/dwc3/dwc3-of-simple.c
+++ b/drivers/usb/dwc3/dwc3-of-simple.c
@@ -26,6 +26,7 @@
@@ -36,10 +34,10 @@ index f9e92ef..49bf556 100644
+ struct reset_control *mstr_rst_30_1;
};
- static int dwc3_of_simple_probe(struct platform_device *pdev)
-@@ -89,6 +92,20 @@ static int dwc3_of_simple_probe(struct platform_device *pdev)
- simple->clks[i] = clk;
- }
+ static int dwc3_of_simple_clk_init(struct dwc3_of_simple *simple, int count)
+@@ -100,6 +103,20 @@ static int dwc3_of_simple_probe(struct p
+ if (ret)
+ return ret;
+ simple->mstr_rst_30_0 = devm_reset_control_get(dev, "usb30_0_mstr_rst");
+
@@ -58,7 +56,7 @@ index f9e92ef..49bf556 100644
ret = of_platform_populate(np, NULL, NULL, dev);
if (ret) {
for (i = 0; i < simple->num_clocks; i++) {
-@@ -117,6 +134,12 @@ static int dwc3_of_simple_remove(struct platform_device *pdev)
+@@ -128,6 +145,12 @@ static int dwc3_of_simple_remove(struct
clk_put(simple->clks[i]);
}
@@ -71,5 +69,3 @@ index f9e92ef..49bf556 100644
of_platform_depopulate(dev);
pm_runtime_put_sync(dev);
---
-cgit v1.1
diff --git a/target/linux/ipq806x/patches-4.9/830-usb-dwc3-register-qca-ipq4019-dwc3-in-dwc3-of-simple.patch b/target/linux/ipq806x/patches-4.9/830-usb-dwc3-register-qca-ipq4019-dwc3-in-dwc3-of-simple.patch
index 18591b205f..ad84eacf7a 100644
--- a/target/linux/ipq806x/patches-4.9/830-usb-dwc3-register-qca-ipq4019-dwc3-in-dwc3-of-simple.patch
+++ b/target/linux/ipq806x/patches-4.9/830-usb-dwc3-register-qca-ipq4019-dwc3-in-dwc3-of-simple.patch
@@ -15,7 +15,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
--- a/drivers/usb/dwc3/dwc3-of-simple.c
+++ b/drivers/usb/dwc3/dwc3-of-simple.c
-@@ -174,6 +174,7 @@ static const struct dev_pm_ops dwc3_of_s
+@@ -197,6 +197,7 @@ static const struct dev_pm_ops dwc3_of_s
static const struct of_device_id of_dwc3_simple_match[] = {
{ .compatible = "qcom,dwc3" },