aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-03-22 09:36:00 +0100
committerJohn Crispin <john@phrozen.org>2017-03-22 09:45:18 +0100
commitd5b10bb560c2c3c615babfcfb64519bfc65818d9 (patch)
tree345dfe911dafc6be300d8945b970a662a34df41c /target/linux/ipq806x
parent7dc561717318c09ec96e25fcbb016a60d03865b7 (diff)
downloadupstream-d5b10bb560c2c3c615babfcfb64519bfc65818d9.tar.gz
upstream-d5b10bb560c2c3c615babfcfb64519bfc65818d9.tar.bz2
upstream-d5b10bb560c2c3c615babfcfb64519bfc65818d9.zip
ipq806x: make the dwc3 driver and required phy drivers built-in
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/config-4.97
-rw-r--r--target/linux/ipq806x/modules.mk31
2 files changed, 6 insertions, 32 deletions
diff --git a/target/linux/ipq806x/config-4.9 b/target/linux/ipq806x/config-4.9
index 072ab6a897..cf16ff4383 100644
--- a/target/linux/ipq806x/config-4.9
+++ b/target/linux/ipq806x/config-4.9
@@ -371,6 +371,7 @@ CONFIG_PERF_USE_VMALLOC=y
CONFIG_PGTABLE_LEVELS=2
CONFIG_PHYLIB=y
# CONFIG_PHY_QCOM_APQ8064_SATA is not set
+CONFIG_PHY_QCOM_DWC3=y
CONFIG_PHY_QCOM_IPQ806X_SATA=y
# CONFIG_PHY_QCOM_UFS is not set
CONFIG_PINCTRL=y
@@ -482,8 +483,12 @@ CONFIG_UEVENT_HELPER_PATH=""
CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
CONFIG_USB=y
CONFIG_USB_COMMON=y
+CONFIG_USB_DWC3=y
+CONFIG_USB_DWC3_HOST=y
+CONFIG_USB_DWC3_OF_SIMPLE=y
# CONFIG_USB_EHCI_HCD is not set
-# CONFIG_USB_IPQ4019_PHY is not set
+CONFIG_USB_IPQ4019_PHY=y
+CONFIG_USB_PHY=y
CONFIG_USB_SUPPORT=y
# CONFIG_USB_UHCI_HCD is not set
CONFIG_USE_OF=y
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
deleted file mode 100644
index 6f1ca2d2a4..0000000000
--- a/target/linux/ipq806x/modules.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-define KernelPackage/usb-dwc3-of-simple
- TITLE:=DWC3 USB simple OF driver
- DEPENDS:=+kmod-usb-dwc3
- KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
- FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
- AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-dwc3-of-simple/description
- This driver provides generic platform glue for the integrated DesignWare
- USB3 IP Core.
-endef
-
-$(eval $(call KernelPackage,usb-dwc3-of-simple))
-
-define KernelPackage/usb-phy-qcom-dwc3
- TITLE:=DWC3 USB QCOM PHY driver
- DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
- KCONFIG:= CONFIG_PHY_QCOM_DWC3
- FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
- AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-phy-qcom-dwc3/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))