aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-09-10 21:40:19 +0000
committerLuka Perkov <luka@openwrt.org>2014-09-10 21:40:19 +0000
commite5441232a81d01e2ed46d88e340a30fd6b15b012 (patch)
treee008cc6bd24a0e2c9b283d94a69f7a027bcfb856 /target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch
parent048910c4e07b6fae28513ce1dea62fe3b6bb03de (diff)
downloadupstream-e5441232a81d01e2ed46d88e340a30fd6b15b012.tar.gz
upstream-e5441232a81d01e2ed46d88e340a30fd6b15b012.tar.bz2
upstream-e5441232a81d01e2ed46d88e340a30fd6b15b012.zip
kernel: update 3.14 to 3.14.18
Targets were build tested and patches are refreshed. Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42463 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch')
-rw-r--r--target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch10
1 files changed, 0 insertions, 10 deletions
diff --git a/target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch b/target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch
index 678a33f472..aaedbb374b 100644
--- a/target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch
+++ b/target/linux/ipq806x/patches/0142-ata-Add-Qualcomm-ARM-SoC-AHCI-SATA-host-controller-d.patch
@@ -16,8 +16,6 @@ Signed-off-by: Kumar Gala <galak@codeaurora.org>
3 files changed, 97 insertions(+)
create mode 100644 drivers/ata/ahci_qcom.c
-diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
-index dc950f3..da05034 100644
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -106,6 +106,16 @@ config AHCI_IMX
@@ -37,8 +35,6 @@ index dc950f3..da05034 100644
config SATA_FSL
tristate "Freescale 3.0Gbps SATA support"
depends on FSL_SOC
-diff --git a/drivers/ata/Makefile b/drivers/ata/Makefile
-index 366b743..e08044f 100644
--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
@@ -11,6 +11,7 @@ obj-$(CONFIG_SATA_SIL24) += sata_sil24.o
@@ -49,9 +45,6 @@ index 366b743..e08044f 100644
# SFF w/ custom DMA
obj-$(CONFIG_PDC_ADMA) += pdc_adma.o
-diff --git a/drivers/ata/ahci_qcom.c b/drivers/ata/ahci_qcom.c
-new file mode 100644
-index 0000000..bfb7a77
--- /dev/null
+++ b/drivers/ata/ahci_qcom.c
@@ -0,0 +1,86 @@
@@ -141,6 +134,3 @@ index 0000000..bfb7a77
+MODULE_DESCRIPTION("Qualcomm AHCI SATA platform driver");
+MODULE_LICENSE("GPL v2");
+MODULE_ALIAS("ahci:qcom");
---
-1.7.10.4
-