aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch
diff options
context:
space:
mode:
authorDongming Han <handongming@gl-inet.com>2017-12-07 20:48:19 +0800
committerJohn Crispin <john@phrozen.org>2018-02-14 09:40:32 +0100
commit04d3308b6248ef21a6f0bc3378b342906c2d2865 (patch)
tree9180681b935ec6494df250411112327f07e9ef9f /target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch
parent88a41074e8e7012c2cb73b85263425c4c474beb1 (diff)
downloadupstream-04d3308b6248ef21a6f0bc3378b342906c2d2865.tar.gz
upstream-04d3308b6248ef21a6f0bc3378b342906c2d2865.tar.bz2
upstream-04d3308b6248ef21a6f0bc3378b342906c2d2865.zip
ipq806x: add support for GL.iNet GL-B1300
This patch adds support for GL.iNet GL-B1300 Specification: - SOC: IPQ4028 / QCA Dakota - RAM: 256 MiB - FLASH: 32 MiB - ETH: Qualcomm Atheros QCA8075 Gigabit Switch (2 x LAN, 1 x WAN) - USB: 1 x 3.0 (via Synopsys DesignWare DWC3 controller in the SoC) - WLAN1: Qualcomm Atheros QCA4028 2.4GHz 802.11bgn 2:2x2 - WLAN2: Qualcomm Atheros QCA4028 5GHz 802.11a/n/ac 2:2x2 - INPUT: one reset and one WPS button - LEDS: 3 leds: Power, WIFI(only for 2.4G currently), and one reserved - UART: 1 x UART on PCB (3.3V, TX, RX, GND) - 115200 8N1 Installation: Method 1: - use serial port to stop uboot - uboot command: run lf Method 2: - push down reset button and power on - wait until three leds constantly on then release - upgrade by uboot web at http://192.168.1.1 Note: - the sysupgrade image need to be renamed to lede-gl-b1300.bin in both method. - the sysupgrade image can be automatically downloaded if tftp server at 192.168.1.2 have that file. - the wifi led will be flashing when writing image. Signed-off-by: Dongming Han <handongming@gl-inet.com>
Diffstat (limited to 'target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch')
-rw-r--r--target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch b/target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch
index faabc24002..0f3b20ebe7 100644
--- a/target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch
+++ b/target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch
@@ -10,11 +10,12 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -616,9 +616,19 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -616,9 +616,20 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-apq8074-dragonboard.dtb \
qcom-apq8084-ifc6540.dtb \
qcom-apq8084-mtp.dtb \
+ qcom-ipq4019-a42.dtb \
++ qcom-ipq4019-gl-b1300.dtb \
qcom-ipq4019-ap.dk01.1-c1.dtb \
qcom-ipq4019-ap.dk04.1-c1.dtb \
+ qcom-ipq4019-fritz4040.dtb \