aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/patches-4.14
diff options
context:
space:
mode:
authorStijn Segers <foss@volatilesystems.org>2018-06-29 22:29:06 +0200
committerJohn Crispin <john@phrozen.org>2018-07-02 07:06:23 +0200
commitab7cabd09df542cf3558725573c2ef2cf1c7cdff (patch)
tree791b3f74b7c5e60f1409836871287337f4cf0e38 /target/linux/ipq806x/patches-4.14
parentc96b344466fc80cb5815eeab87c6ca9a29fb9207 (diff)
downloadupstream-ab7cabd09df542cf3558725573c2ef2cf1c7cdff.tar.gz
upstream-ab7cabd09df542cf3558725573c2ef2cf1c7cdff.tar.bz2
upstream-ab7cabd09df542cf3558725573c2ef2cf1c7cdff.zip
kernel: bump 4.14 to 4.14.52 for 18.06
Compile-tested on: ramips/mt7621, x86/64. Run-tested on: ramips/mt7621. Signed-off-by: Stijn Segers <foss@volatilesystems.org>
Diffstat (limited to 'target/linux/ipq806x/patches-4.14')
-rw-r--r--target/linux/ipq806x/patches-4.14/0035-clk-mux-Split-out-register-accessors-for-reuse.patch6
-rw-r--r--target/linux/ipq806x/patches-4.14/0069-arm-boot-add-dts-files.patch12
2 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/ipq806x/patches-4.14/0035-clk-mux-Split-out-register-accessors-for-reuse.patch b/target/linux/ipq806x/patches-4.14/0035-clk-mux-Split-out-register-accessors-for-reuse.patch
index 0d919ee668..e65ca02980 100644
--- a/target/linux/ipq806x/patches-4.14/0035-clk-mux-Split-out-register-accessors-for-reuse.patch
+++ b/target/linux/ipq806x/patches-4.14/0035-clk-mux-Split-out-register-accessors-for-reuse.patch
@@ -135,14 +135,14 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
if (mux->lock)
spin_lock_irqsave(mux->lock, flags);
else
-@@ -102,14 +121,14 @@ static int clk_mux_set_parent(struct clk
+@@ -110,14 +129,14 @@ static int clk_mux_determine_rate(struct
}
const struct clk_ops clk_mux_ops = {
- .get_parent = clk_mux_get_parent,
+ .get_parent = _clk_mux_get_parent,
.set_parent = clk_mux_set_parent,
- .determine_rate = __clk_mux_determine_rate,
+ .determine_rate = clk_mux_determine_rate,
};
EXPORT_SYMBOL_GPL(clk_mux_ops);
@@ -152,7 +152,7 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
};
EXPORT_SYMBOL_GPL(clk_mux_ro_ops);
-@@ -117,7 +136,7 @@ struct clk_hw *clk_hw_register_mux_table
+@@ -125,7 +144,7 @@ struct clk_hw *clk_hw_register_mux_table
const char * const *parent_names, u8 num_parents,
unsigned long flags,
void __iomem *reg, u8 shift, u32 mask,
diff --git a/target/linux/ipq806x/patches-4.14/0069-arm-boot-add-dts-files.patch b/target/linux/ipq806x/patches-4.14/0069-arm-boot-add-dts-files.patch
index 59f37a7027..b94e4828c9 100644
--- a/target/linux/ipq806x/patches-4.14/0069-arm-boot-add-dts-files.patch
+++ b/target/linux/ipq806x/patches-4.14/0069-arm-boot-add-dts-files.patch
@@ -11,9 +11,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -699,6 +699,16 @@ dtb-$(CONFIG_ARCH_QCOM) += \
- qcom-apq8084-mtp.dtb \
- qcom-ipq4019-ap.dk01.1-c1.dtb \
- qcom-ipq8064-ap148.dtb \
+ qcom-apq8084-mtp.dtb \
+ qcom-ipq4019-ap.dk01.1-c1.dtb \
+ qcom-ipq8064-ap148.dtb \
+ qcom-ipq8064-c2600.dtb \
+ qcom-ipq8064-d7800.dtb \
+ qcom-ipq8064-db149.dtb \
@@ -24,6 +24,6 @@ Signed-off-by: John Crispin <john@phrozen.org>
+ qcom-ipq8064-wpq864.dtb \
+ qcom-ipq8065-nbg6817.dtb \
+ qcom-ipq8065-r7800.dtb \
- qcom-msm8660-surf.dtb \
- qcom-msm8960-cdp.dtb \
- qcom-msm8974-lge-nexus5-hammerhead.dtb \
+ qcom-msm8660-surf.dtb \
+ qcom-msm8960-cdp.dtb \
+ qcom-msm8974-lge-nexus5-hammerhead.dtb \