aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-03-23 08:29:21 +0100
committerJohn Crispin <john@phrozen.org>2017-03-23 08:29:44 +0100
commit666bfc6fb554441f1940eba84e00be10487e2463 (patch)
tree358a29bbdec20111d362b16bf5b7f943452a4a96 /target/linux/ipq806x/modules.mk
parent4d5b5c82e1304d85e3fbae445c42d36942a2cbe0 (diff)
downloadupstream-666bfc6fb554441f1940eba84e00be10487e2463.tar.gz
upstream-666bfc6fb554441f1940eba84e00be10487e2463.tar.bz2
upstream-666bfc6fb554441f1940eba84e00be10487e2463.zip
Revert "ipq806x: make the dwc3 driver and required phy drivers built-in"
This reverts commit d5b10bb560c2c3c615babfcfb64519bfc65818d9. This caused boot errors on some ipq8 boards Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ipq806x/modules.mk')
-rw-r--r--target/linux/ipq806x/modules.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
new file mode 100644
index 0000000000..6f1ca2d2a4
--- /dev/null
+++ b/target/linux/ipq806x/modules.mk
@@ -0,0 +1,31 @@
+define KernelPackage/usb-dwc3-of-simple
+ TITLE:=DWC3 USB simple OF driver
+ DEPENDS:=+kmod-usb-dwc3
+ KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
+ FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
+ AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc3-of-simple/description
+ This driver provides generic platform glue for the integrated DesignWare
+ USB3 IP Core.
+endef
+
+$(eval $(call KernelPackage,usb-dwc3-of-simple))
+
+define KernelPackage/usb-phy-qcom-dwc3
+ TITLE:=DWC3 USB QCOM PHY driver
+ DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
+ KCONFIG:= CONFIG_PHY_QCOM_DWC3
+ FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
+ AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-phy-qcom-dwc3/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-phy-qcom-dwc3))