aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorPeter Geis <pgwipeout@gmail.com>2021-09-13 11:08:57 -0400
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-10-26 22:30:18 +0200
commit70c12d26ca6eb01a938feb38f89720d78df0ca6d (patch)
tree64d7039ba38c9bda9fc769b389de14c4f0f85d8b /target/linux/ipq806x/image
parent2c3e8bed3f04f426d676d6352018b33a49a72406 (diff)
downloadupstream-70c12d26ca6eb01a938feb38f89720d78df0ca6d.tar.gz
upstream-70c12d26ca6eb01a938feb38f89720d78df0ca6d.tar.bz2
upstream-70c12d26ca6eb01a938feb38f89720d78df0ca6d.zip
ipq806x: add support for Netgear Nighthawk Pro Gaming XR500
This adds support for the Netgear Nighthawk Pro Gaming XR500. It is the successor to the Netgear Nighthawk R7800 and shares almost identical hardware to that device. The stock firmware is a heavily modified version of OpenWRT. Specifications: SoC: Qualcomm Atheros IPQ8065 RAM: 512 MB Storage: 256 MiB NAND Flash Wireless: 2x Qualcomm Atheros QCA9984 Ethernet: 2x 1000/100/10 dedicated interfaces Switch: 5x 1000/100/10 external ports USB: 2x 3.0 ports More information: Manufacturer page: https://www.netgear.com/gaming/xr500/ Almost identical to Netgear R7800 Differences (r7800 > xr500): Flash: 128MiB > 256MiB Removed esata swapped leds: usb1 (gpio 7 > 8) usb2 (gpio 8 > 26) guest/esata (gpio 26 > 7) MAC addresses: On the OEM firmware, the mac addresses are: WAN: *:50 art 0x6 LAN: *:4f art 0x0 (label) 2G: *:4f art 0x0 5G: *:51 art 0xc Installation: Install via Web Interface (preferred): Utilize openwrt-ipq806x-netgear_xr500-squashfs-factory.img Install via TFTP recovery: 1.Turn off the power, push and hold the reset button (in a hole on backside) with a pin 2.Turn on the power and wait till power led starts flashing white (after it first flashes orange for a while) 3.Release the reset button and tftp the factory img in binary mode. The power led will stop flashing if you succeeded in transferring the image, and the router reboots rather quickly with the new firmware. 4.Try to ping the router (ping 192.168.1.1). If does not respond, then tftp will not work either. Uploading the firmware image with a TFTP client $ tftp 192.168.1.1 bin put openwrt-ipq806x-netgear_xr500-squashfs-factory.img Note: The end of the last partition is at 0xee00000. This was chosen by the initial author, but nobody was able to tell why this particular arbitrary size was chosen. Since it's not leaving too much empty space and it's the only issue left, let's just keep it for now. Based on work by Adam Hnat <adamhnat@gmail.com> ref: https://github.com/openwrt/openwrt/pull/3215 Signed-off-by: Peter Geis <pgwipeout@gmail.com> [squash commits, move common LEDs to DTSI, remove SPDX on old files, minor whitespace cleanup, commit message facelift, add MAC address overview, add Notes, fix MAC addresses, use generic name for partition nodes in DTS] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 93e7ba3151..acb95347bf 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -284,6 +284,20 @@ define Device/netgear_r7800
endef
TARGET_DEVICES += netgear_r7800
+define Device/netgear_xr500
+ $(call Device/DniImage)
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := Nighthawk XR500
+ SOC := qcom-ipq8065
+ KERNEL_SIZE := 4096k
+ NETGEAR_BOARD_ID := XR500
+ NETGEAR_HW_ID := 29764958+0+256+512+4x4+4x4+cascade
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
+endef
+TARGET_DEVICES += netgear_xr500
+
define Device/qcom_ipq8064-ap148
$(call Device/FitImage)
$(call Device/UbiFit)