aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-06 19:04:15 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-06 19:05:53 +0000
commite991c1b8a2385397fc1e657ed73878938997d951 (patch)
treed4db0ea7e20921baa043763c3018b2a41700479e /target/linux/ipq806x/image
parent969083634481c3ab5fb80509f385ef10ab45b55f (diff)
downloadupstream-e991c1b8a2385397fc1e657ed73878938997d951.tar.gz
upstream-e991c1b8a2385397fc1e657ed73878938997d951.tar.bz2
upstream-e991c1b8a2385397fc1e657ed73878938997d951.zip
ipq806x: work-around borked QCA SDK bootloader
The bootloader of many ipq806x boards seems to require the config node of the FIT image to be 'config@1' (or a secific different value). This requirement used to be implicitely satisfied because OpenWrt used to also call the configuration node inside a FIT image 'config@1'. However, as recent U-Boot now prohibits the use of the '@' symbol as part of node names, this was changed by commit 5ec60cbe9d ("scripts: mkits.sh: replace @ with - in nodes") Explicitely restore the default name of the configuration node to 'config@1' on ipq806x. (ipq807x is unaffected as DEVICE_DTS_CONFIG default is set "config@hk01" in target/linux/ipq807x/image/Makefile) Reported-by: Chen Minqiang <ptpt52@gmail.com> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index cb4058f4a1..6c091be335 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -28,6 +28,7 @@ define Device/Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_LOADADDR = 0x42208000
DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+ DEVICE_DTS_CONFIG := config@1
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
IMAGE/sysupgrade.bin/squashfs :=