aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorGary Cooper <gaco@bitmessage.de>2021-01-04 20:27:50 +0300
committerDaniel Golle <daniel@makrotopia.org>2021-01-05 02:16:24 +0000
commit1a775a4fd0339b485f48a864e2cf9e8794bfe4cb (patch)
treeb3d59b898ea776aefafede31d21e245d32fe69ef /target/linux/ipq806x/image
parent6442b8cbc2e4c53ffa4a6b7c30c2571dac87902d (diff)
downloadupstream-1a775a4fd0339b485f48a864e2cf9e8794bfe4cb.tar.gz
upstream-1a775a4fd0339b485f48a864e2cf9e8794bfe4cb.tar.bz2
upstream-1a775a4fd0339b485f48a864e2cf9e8794bfe4cb.zip
ipq806x: add support for TP-Link Talon AD7200
Device hardware: https://deviwiki.com/wiki/TP-LINK_AD7200_(Talon) The Talon AD7200 is basically an Archer C2600 with a third PCIe lane and an 802.11ad radio. It looks like the Archers C2600/5400 but the housing is slightly larger. Specifications -------------- - IPQ8064 dual-core 1400MHz - QCA9988 2.4GHz WiFi - QCA9990 5GHz WiFi - QCA9500 60GHz WiFi - 32MB SPI Flash - 512MiB RAM - 5 GBit Ports (QCA8337) Installation ------------ Installation is possible from the OEM web interface. Sysupgrade is possible. TFTP recovery is possible. - Image: AD7200_1.0_tp_recovery.bin Notes - This will be the first 802.11ad device supported by mainline. Signed-off-by: Gary Cooper <gaco@bitmessage.de>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 80bfec5ad9..876f337bba 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -333,6 +333,21 @@ define Device/qcom_ipq8064-db149
endef
TARGET_DEVICES += qcom_ipq8064-db149
+define Device/tplink_ad7200
+ $(call Device/TpSafeImage)
+ DEVICE_VENDOR := TP-Link
+ DEVICE_MODEL := Talon AD7200
+ DEVICE_VARIANT := v1
+ SOC := qcom-ipq8064
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := ad7200
+ SUPPORTED_DEVICES += ad7200
+ TPLINK_BOARD_ID := AD7200
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct kmod-wil6210
+endef
+TARGET_DEVICES += tplink_ad7200
+
define Device/tplink_c2600
$(call Device/TpSafeImage)
DEVICE_VENDOR := TP-Link