aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-01-14 22:03:41 +0100
committerMathias Kresin <dev@kresin.me>2018-01-15 21:45:43 +0100
commitf2a8e02134315e7a40f10b38bc4d977efd0ce3c7 (patch)
treeb8397b6c0017299e252f2db6d0b9fc2f2e53bf06 /target/linux/ipq806x/image/Makefile
parent7488be701029a86259dcd297a3c665eb65bdac6e (diff)
downloadupstream-f2a8e02134315e7a40f10b38bc4d977efd0ce3c7.tar.gz
upstream-f2a8e02134315e7a40f10b38bc4d977efd0ce3c7.tar.bz2
upstream-f2a8e02134315e7a40f10b38bc4d977efd0ce3c7.zip
ipq806x: use bin file extension for sysupgrade-tar images
Use the file extension bin for sysupgrade-tar images to unify the file extension across the target/tree. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 708150521e..db6c94c0ac 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -30,7 +30,7 @@ define Device/Default
KERNEL_PREFIX := $$(IMAGE_PREFIX)
KERNEL_LOADADDR = 0x42208000
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
- IMAGE/sysupgrade.tar = sysupgrade-tar | append-metadata
+ IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
endef
define Device/LegacyImage
@@ -53,9 +53,9 @@ endef
define Device/UbiFit
KERNEL_IN_UBI := 1
- IMAGES := nand-factory.ubi nand-sysupgrade.tar
+ IMAGES := nand-factory.ubi nand-sysupgrade.bin
IMAGE/nand-factory.ubi := append-ubi
- IMAGE/nand-sysupgrade.tar := sysupgrade-tar | append-metadata
+ IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
endef
define Device/DniImage
@@ -67,9 +67,9 @@ define Device/DniImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
UBINIZE_OPTS := -E 5
- IMAGES := factory.img sysupgrade.tar
+ IMAGES := factory.img sysupgrade.bin
IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-ubi | netgear-dni
- IMAGE/sysupgrade.tar := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | sysupgrade-tar kernel=$$$$@ | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | sysupgrade-tar kernel=$$$$@ | append-metadata
endef
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
@@ -92,8 +92,8 @@ define Device/ZyXELImage
KERNEL_SUFFIX := -uImage
KERNEL = kernel-bin | append-dtb | uImage none | pad-to $${KERNEL_SIZE}
KERNEL_NAME := zImage
- IMAGES := sysupgrade.tar mmcblk0p5-rootfs.bin mmcblk0p4-kernel.bin
- IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ IMAGES := sysupgrade.bin mmcblk0p5-rootfs.bin mmcblk0p4-kernel.bin
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@ | append-metadata
IMAGE/mmcblk0p5-rootfs.bin := append-rootfs | pad-rootfs | pad-to $$$${BLOCKSIZE}
IMAGE/mmcblk0p4-kernel.bin := append-kernel
endef
@@ -125,7 +125,7 @@ define Device/linksys_ea8500
BOARD_NAME := ea8500
SUPPORTED_DEVICES += ea8500
UBINIZE_OPTS := -E 5
- IMAGES := factory.bin sysupgrade.tar
+ IMAGES := factory.bin sysupgrade.bin
IMAGE/factory.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi
DEVICE_TITLE := Linksys EA8500
DEVICE_PACKAGES := ath10k-firmware-qca99x0