aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorRam Chandra Jangir <rjangir@codeaurora.org>2017-05-31 20:50:29 +0530
committerJohn Crispin <john@phrozen.org>2017-06-07 06:33:33 +0200
commite178d51a044c0eac1a56fa404c7da7361e336068 (patch)
tree4aa0cbae7bebbe7991c793b2aaa588f459018ed3 /target/linux/ipq806x/image/Makefile
parent5e1cc0c09082458731fb38f3d265ec3ca193c65e (diff)
downloadupstream-e178d51a044c0eac1a56fa404c7da7361e336068.tar.gz
upstream-e178d51a044c0eac1a56fa404c7da7361e336068.tar.bz2
upstream-e178d51a044c0eac1a56fa404c7da7361e336068.zip
ipq806x: Enable ubi image for ipq40xx AP-DK04.1-C1 board
This change add IPQ40xx AP-DK04.1-C1 board image support, enables ubi image for IPQ40xx AP-DK04.1-C1 board and also add sysupgrage support for AP-DK04.1-C1 and generates a sysupgrade.tar image. Testing: *Tested on IPQ40xx AP-DK04.1-C1: a. NAND boot b. ubi sysupgrade Signed-off-by: Ram Chandra Jangir <rjangir@codeaurora.org>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index de6ddb6a93..4ed05eb940 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -250,7 +250,20 @@ define Device/VR2600v
IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
endef
+define Device/AP-DK04.1-C1
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
+ KERNEL_LOADADDR := 0x80208000
+ KERNEL_INSTALL := 1
+ KERNEL_SIZE := 4048k
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := ap-dk04.1-c1
+ DEVICE_TITLE := QCA AP-DK04.1-C1
+endef
+
TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 FRITZ4040 R7500 \
- R7500v2 R7800 NBG6817 VR2600v
+ R7500v2 R7800 NBG6817 VR2600v AP-DK04.1-C1
$(eval $(call BuildImage))