aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorRam Chandra Jangir <rjangir@codeaurora.org>2018-10-19 16:47:42 +0530
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:46 +0100
commitdc6af375441eeb2ba9143c2d85d6c91534703d10 (patch)
tree624f71570b7048f25ebe138263a374b43adca85d /target/linux/ipq806x/image/Makefile
parent1ade96def7b6c97d2d4380446dead672197a8447 (diff)
downloadupstream-dc6af375441eeb2ba9143c2d85d6c91534703d10.tar.gz
upstream-dc6af375441eeb2ba9143c2d85d6c91534703d10.tar.bz2
upstream-dc6af375441eeb2ba9143c2d85d6c91534703d10.zip
ipq806x: Add support for IPQ8064 AP161 board
Specification: - SoC: Qualcomm Atheros IPQ8064 ARM-v7 Dual Core SMP CPU - RAM: 512MB DDR3 System Memory - NOR Flash: 32MB SPI NOR - NAND Flash: 256MB NAND - Ethernet: 5 x 1G via QCA8337N - USB: 2 x USB 3.0 SuperSpeed - PCIe: 3x Mini PCIe 2.0 Slots Three PCIE2.0 connectors can connect two or three radio cards such as the CUS260 for 2.4 GHz WLAN and the CUS239 for 802.11ac WLAN How to flash via u-boot console: tftpboot 0x44000000 openwrt-ipq806x-qcom_ipq8064-ap161-squashfs-nand-factory.bin nand erase 0x1340000 0x4000000 nand write 0x44000000 0x1340000 $filesize setenv bootargs ‘console=ttyMSM0,115200 ubi.mtd=ubi root=/dev/ubiblock0_1’ saveenv bootm Further upgrades via sysupgrade. Tested on IPQ8064 AP161 Board: 1) NAND boot 2) Tested USB and PCIe interfaces 3) WDOG test 4) cpu frequency scaling 5) ethernet, 2G and 5G WiFi 6) ubi sysupgrade Signed-off-by: Ram Chandra Jangir <rjangir@codeaurora.org>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b82d54b0f6..5902eee6ac 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -201,6 +201,19 @@ define Device/qcom_ipq8064-ap148-legacy
endef
TARGET_DEVICES += qcom_ipq8064-ap148-legacy
+define Device/qcom_ipq8064-ap161
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_DTS := qcom-ipq8064-ap161
+ KERNEL_INSTALL := 1
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := ap161
+ DEVICE_TITLE := Qualcomm AP161
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += qcom_ipq8064-ap161
+
define Device/qcom_ipq8064-db149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149