aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2018-05-18 04:12:04 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:34:14 +0200
commitc228bbe616a52921a9d8fc961b3efcbdd3880c25 (patch)
tree46af68be3bf2d6cbf7810580c4b569087b7fcfdf /target/linux/ipq806x/image/Makefile
parent45b8a7c1a6415125f4fe872ec83b3d31a2fa799b (diff)
downloadupstream-c228bbe616a52921a9d8fc961b3efcbdd3880c25.tar.gz
upstream-c228bbe616a52921a9d8fc961b3efcbdd3880c25.tar.bz2
upstream-c228bbe616a52921a9d8fc961b3efcbdd3880c25.zip
ipq806x: increase kernel partition size for the Netgear Nighthawk X4 R7500
Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the 2 MB reserved for the kernel partition by the OEM firmware anymore. This patch increases the kernel partition from 2 MB to 4 MB, at the expense of the rootfs, for all supported kernels. WARNING: This breaks sysupgrade! Flashing a firmware containing this changed partitioning from an older image with 2 MB reserved for the kernel partion requires the tftp recovery procedure, thereby losing all settings. This change follows the functional example of the Netgear r7800, but has not been runtime tested on a Netgear Nighthawk X4 R7500 Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> Cc: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 496564de38..5a1faa3ead 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -119,7 +119,7 @@ TARGET_DEVICES += netgear_d7800
define Device/netgear_r7500
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-r7500
- KERNEL_SIZE := 2097152
+ KERNEL_SIZE := 4194304
NETGEAR_BOARD_ID := R7500
NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
BLOCKSIZE := 128k