aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2017-01-23 14:40:10 +0100
committerMathias Kresin <dev@kresin.me>2017-01-27 11:10:10 +0100
commitaeba0fe466b5e850d0cf0697fc120070230d7831 (patch)
tree01969177a4171caadee82f0ef7c0b4d215d318fe /target/linux/ipq806x/image/Makefile
parent99eb6f97e519d5ab7870345ef0ae4680d1c92166 (diff)
downloadupstream-aeba0fe466b5e850d0cf0697fc120070230d7831.tar.gz
upstream-aeba0fe466b5e850d0cf0697fc120070230d7831.tar.bz2
upstream-aeba0fe466b5e850d0cf0697fc120070230d7831.zip
build: move append-file to image-commands.mk
Move it append-file to image-commands.mk so that it can used by other targets as well. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 3cc48bb905..33dc31d41e 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -31,10 +31,6 @@ define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-root.img bs=2k conv=sync
endef
-define Build/append-file
- cat $(1) >> $@
-endef
-
define Device/Default
PROFILES := Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)