aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorSebastian Quilitz <zeraphim@x-pantion.de>2016-11-23 18:51:15 +0100
committerMathias Kresin <dev@kresin.me>2016-11-24 22:37:40 +0100
commitae79c41286f0d9a97f2641450240ecac5465677d (patch)
tree03b5e25c4d5792e730add0a6a9ddf0e323e1f842 /target/linux/ipq806x/image/Makefile
parent0e7869f20492a76fc1f331101fa01bfe9f02692f (diff)
downloadupstream-ae79c41286f0d9a97f2641450240ecac5465677d.tar.gz
upstream-ae79c41286f0d9a97f2641450240ecac5465677d.tar.bz2
upstream-ae79c41286f0d9a97f2641450240ecac5465677d.zip
ipq806x: add support for TP-Link Archer VR2600v
This router is similar to the C2600. Ethernet on WAN + LAN, switch, sysupgrade, LEDs, buttons and WiFi on 2G + 5G do work. The xDSL modem and the POTS/DECT interface are not supported yet. It is not possible to flash LEDE via the TP-Link webinterface. The image need to be signed. The first 0x200 bytes of the image is the TP-Link header including the signature. The signature is not validated by the bootloader. The LEDE image is zeroed in this area. To install LEDE it is necessary to solder a four pin header to JP2. Connect a serial interface to this header and interrupt the autostart of kernel. Transfer the sysupgrade image via TFTP and write it to the serial flash at 0x320000. Signed-off-by: Sebastian Quilitz <zeraphim@x-pantion.de>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 47c28ab651..3cc48bb905 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -224,6 +224,23 @@ define Device/NBG6817
$(call Device/ZyXELImage)
endef
-TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800 NBG6817
+define Device/VR2600v
+ PROFILES += $$(DEVICE_NAME)
+ FILESYSTEMS := squashfs
+ KERNEL_SUFFIX := -uImage
+ KERNEL = kernel-bin | append-dtb | uImage none
+ KERNEL_NAME := zImage
+ KERNEL_SIZE := 2097152
+ DEVICE_DTS := qcom-ipq8064-vr2600v
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := vr2600v
+ DEVICE_TITLE := TP-Link Archer VR2600v
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+endef
+
+TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800 NBG6817 VR2600v
$(eval $(call BuildImage))