aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorAndré Valentin <avalentin@marcant.net>2016-10-25 08:40:34 +0200
committerJohn Crispin <john@phrozen.org>2016-10-26 12:37:46 +0200
commita0ed7af6c62bb8972ce7509ac76d0a648b291dd6 (patch)
tree2ef8b201bb7a7e0c15bc81e433730608d939874b /target/linux/ipq806x/image/Makefile
parent91b518512d197257b2e1a4d482e8bfe8ffbbc20c (diff)
downloadupstream-a0ed7af6c62bb8972ce7509ac76d0a648b291dd6.tar.gz
upstream-a0ed7af6c62bb8972ce7509ac76d0a648b291dd6.tar.bz2
upstream-a0ed7af6c62bb8972ce7509ac76d0a648b291dd6.zip
ipq806x/nbg6817: add support for ZyXEL NBG6817
CPU: 2x1.8GHz ARM, RAM: 512MiB Storage: 4MiB serial Flash, 3.9GiB MMC NIC: 2x1GBit/s, Switch with 5 external and 2 internal ports WiFi: Dualband, ath10k 2.4GHz, 5GHz MU-MIMO For installation copy xx-mmcblk0p4-kernel.bin and xx-mmcblk0p5-rootfs-full.bin to device. Then run: cat xx-mmcblk0p4-kernel.bin > /dev/mmc0blk0p4 cat xx-mmcblk0p5-rootfs-full.bin > /dev/mmc0blk0p5 reboot -f For debugging serial console is easily visible on board, no soldering needed. Signed-off-by: André Valentin <avalentin@marcant.net>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile25
1 files changed, 24 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b74f1a77c2..3bee923f93 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -90,6 +90,19 @@ define Device/TpSafeImage
endef
DEVICE_VARS += TPLINK_BOARD_NAME
+define Device/ZyXELImage
+ PROFILES += $$(DEVICE_NAME)
+ FILESYSTEMS := squashfs
+ KERNEL_SUFFIX := -uImage
+ KERNEL = kernel-bin | append-dtb | uImage none | pad-to $$$${KERNEL_SIZE}
+ KERNEL_NAME := zImage
+ IMAGES := sysupgrade.tar mmcblk0p5-rootfs.bin mmcblk0p4-kernel.bin
+ IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@
+ IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGE/mmcblk0p5-rootfs.bin := append-rootfs | pad-rootfs | pad-to $$$${BLOCKSIZE}
+ IMAGE/mmcblk0p4-kernel.bin := append-kernel
+endef
+
define Device/AP148
$(call Device/FitImage)
$(call Device/UbiFit)
@@ -202,6 +215,16 @@ define Device/R7800
DEVICE_PACKAGES := ath10k-firmware-qca9984
endef
-TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800
+define Device/NBG6817
+ DEVICE_DTS := qcom-ipq8065-nbg6817
+ KERNEL_SIZE := 4096k
+ BLOCKSIZE := 64k
+ BOARD_NAME := nbg6817
+ DEVICE_TITLE := ZyXEL NBG6817
+ DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs losetup
+ $(call Device/ZyXELImage)
+endef
+
+TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800 NBG6817
$(eval $(call BuildImage))