aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 18:09:37 +0100
committerMathias Kresin <dev@kresin.me>2017-04-08 14:30:00 +0200
commit8b3fa168b49a4aad5797ef5083c17c348d99731b (patch)
treed7eac940d191855a585876a1a8018549981ca04d /target/linux/ipq806x/image/Makefile
parent136718a3d91bb392de8bc04d9fd59d86b4f460c0 (diff)
downloadupstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.gz
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.bz2
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.zip
firmware: rework fritz-tools package
Split the fritz-tools into subpackages. fritz_tffs_read is usefull for all Fritz boards where fritz-cal_extract is only required for the Fritz 4040 at the moment. Rename the tffs related binary to the more catchy name fritz_tffs and move the whole package to utilities since the package doesn't really provide a firmware file. Make the fritz-tools available for all targets and build them shared. The tffs is used by avm on lantiq and ar71xx as well. Tested-by: Christian Lamparter <chunkeey@googlemail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index f67e6b23ef..de6ddb6a93 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -181,7 +181,7 @@ define Device/FRITZ4040
IMAGE_SIZE := 29753344
IMAGES = sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tools u-boot-fritz4040
+ DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tffs fritz-caldata u-boot-fritz4040
endef
define Device/R7500