aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorSven Eckelmann <sven.eckelmann@open-mesh.com>2017-11-30 14:30:06 +0100
committerMathias Kresin <dev@kresin.me>2018-01-13 08:00:14 +0100
commit86e18f6706e1f2c881fb6a2b9facf108573416e6 (patch)
tree5d9fcc9b5552c7b82efad5cedcfe4d4efdecd870 /target/linux/ipq806x/image/Makefile
parentc242643d1aba0f065b4a465cd78f0c54dd7cb3b2 (diff)
downloadupstream-86e18f6706e1f2c881fb6a2b9facf108573416e6.tar.gz
upstream-86e18f6706e1f2c881fb6a2b9facf108573416e6.tar.bz2
upstream-86e18f6706e1f2c881fb6a2b9facf108573416e6.zip
ipq806x: add support for OpenMesh A42
* QCA IPQ401x * 256 MB of RAM * 32 MB of SPI NOR flash (s25fl256s1) - 2x 15 MB available; but one of the 15 MB regions is the recovery image * 2T2R 2.4 GHz - QCA4019 hw1.0 (SoC) - requires special BDF in QCA4019/hw1.0/board-2.bin with bus=ahb,bmi-chip-id=0,bmi-board-id=16,variant=OM-A42 * 2T2R 5 GHz - QCA4019 hw1.0 (SoC) - requires special BDF in QCA4019/hw1.0/board-2.bin with bus=ahb,bmi-chip-id=0,bmi-board-id=17,variant=OM-A42 * multi-color LED (controlled via red/green/blue GPIOs) * 1x button (reset; kmod-input-gpio-keys compatible) * external watchdog - triggered GPIO * 1x USB (xHCI) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x gigabit ethernet * powered only via POE - 802.3af POE on Ethernet 1 - 18-24v passive POE (mode B) on Ethernet 2 The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the factory image to the u-boot when the device boots up. Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index e8182e858f..708150521e 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -192,6 +192,23 @@ define Device/netgear_r7800
endef
TARGET_DEVICES += netgear_r7800
+define Device/openmesh_a42
+ $(call Device/FitImageLzma)
+ FILESYSTEMS := squashfs
+ DEVICE_DTS := qcom-ipq4019-a42
+ KERNEL_LOADADDR := 0x80208000
+ BLOCKSIZE := 64k
+ SUPPORTED_DEVICES := openmesh,a42
+ DEVICE_TITLE := OpenMesh A42
+ KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+ IMAGE_SIZE := 15616k
+ IMAGES = factory.bin sysupgrade.bin
+ IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ DEVICE_PACKAGES := ath10k-firmware-qca4019 uboot-envtools ipq-wifi-openmesh_a42
+endef
+TARGET_DEVICES += openmesh_a42
+
define Device/qcom_ap-dk01.1-c1
PROFILES += $$(DEVICE_NAME)
DEVICE_TITLE := QCA AP-DK01.1-C1