aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-04-20 06:30:46 +0200
committerMathias Kresin <dev@kresin.me>2018-04-20 20:58:52 +0200
commit74a0d8cd92c7e753c6a342a7b90151ec042a03c5 (patch)
treef0fb63e26b872c1e799d8cf729182df3a2d8861d /target/linux/ipq806x/image/Makefile
parent5950ab067bcc6ffa9ab6bb0c28c8d9ca45d34eb7 (diff)
downloadupstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.gz
upstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.bz2
upstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.zip
build: consolidate fake uImage header build commands
Merge the two existing functions and use a parameter for the type header field. It updates the syntax of the former mpc85xx fake ramdisk header command to be compatible with mkimage from u-boot 2018.03 and fixes the build error spotted by the build bot. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 73b6ca8c34..a737e165b0 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -47,8 +47,8 @@ define Device/DniImage
NETGEAR_HW_ID :=
UBINIZE_OPTS := -E 5
IMAGES := factory.img sysupgrade.bin
- IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-ubi | netgear-dni
- IMAGE/sysupgrade.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | sysupgrade-tar kernel=$$$$@ | append-metadata
+ IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | netgear-dni
+ IMAGE/sysupgrade.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakehdr filesystem | sysupgrade-tar kernel=$$$$@ | append-metadata
endef
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
@@ -90,7 +90,7 @@ define Device/linksys_ea8500
PAGESIZE := 2048
BLOCKSIZE := 128k
KERNEL_SIZE := 3072k
- KERNEL = kernel-bin | append-dtb | uImage none | append-uImage-fakeroot-hdr
+ KERNEL = kernel-bin | append-dtb | uImage none | append-uImage-fakehdr filesystem
BOARD_NAME := ea8500
SUPPORTED_DEVICES += ea8500
UBINIZE_OPTS := -E 5