aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-01-05 10:11:16 -0300
committerMathias Kresin <dev@kresin.me>2018-01-13 07:33:03 +0100
commit7293499f719d73ffaeb61011d077e84d309b0f25 (patch)
tree0f5a502160b6ebff268589609d0136d247dba820 /target/linux/ipq806x/image/Makefile
parent33f09cf15178cf7e05cbe816e1cb492bcae89836 (diff)
downloadupstream-7293499f719d73ffaeb61011d077e84d309b0f25.tar.gz
upstream-7293499f719d73ffaeb61011d077e84d309b0f25.tar.bz2
upstream-7293499f719d73ffaeb61011d077e84d309b0f25.zip
ipq806x: Sort occurrences of boardame alphabetically
This restores the alphabetical sort that was present before the renaming of boardname. Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile214
1 files changed, 107 insertions, 107 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index f28f4a3b7a..e8182e858f 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -98,70 +98,20 @@ define Device/ZyXELImage
IMAGE/mmcblk0p4-kernel.bin := append-kernel
endef
-define Device/qcom_ipq8064-ap148
- $(call Device/FitImage)
- $(call Device/UbiFit)
- DEVICE_DTS := qcom-ipq8064-ap148
- KERNEL_INSTALL := 1
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- BOARD_NAME := ap148
- SUPPORTED_DEVICES += ap148
- DEVICE_TITLE := Qualcomm AP148
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
-endef
-TARGET_DEVICES += qcom_ipq8064-ap148
-
-define Device/qcom_ipq8064-ap148-legacy
- $(call Device/LegacyImage)
- $(call Device/UbiFit)
- DEVICE_DTS := qcom-ipq8064-ap148
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- BOARD_NAME := ap148
- SUPPORTED_DEVICES := qcom,ipq8064-ap148 ap148
- DEVICE_TITLE := Qualcomm AP148 (legacy)
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
-endef
-TARGET_DEVICES += qcom_ipq8064-ap148-legacy
-
-define Device/tplink_c2600
- $(call Device/TpSafeImage)
- DEVICE_DTS := qcom-ipq8064-c2600
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- BOARD_NAME := c2600
- SUPPORTED_DEVICES += c2600
- TPLINK_BOARD_ID := C2600
- DEVICE_TITLE := TP-Link Archer C2600
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
-endef
-TARGET_DEVICES += tplink_c2600
-
-define Device/netgear_d7800
- $(call Device/DniImage)
- DEVICE_DTS := qcom-ipq8064-d7800
- KERNEL_SIZE := 2097152
- NETGEAR_BOARD_ID := D7800
- NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- BOARD_NAME := d7800
- SUPPORTED_DEVICES += d7800
- DEVICE_TITLE := Netgear Nighthawk X4 D7800
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
-endef
-TARGET_DEVICES += netgear_d7800
-
-define Device/qcom_ipq8064-db149
- $(call Device/FitImage)
- DEVICE_DTS := qcom-ipq8064-db149
- KERNEL_INSTALL := 1
- BOARD_NAME := db149
- DEVICE_TITLE := Qualcomm DB149
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+define Device/avm_fritzbox-4040
+ $(call Device/FitImageLzma)
+ DEVICE_DTS := qcom-ipq4019-fritz4040
+ KERNEL_LOADADDR := 0x80208000
+ BLOCKSIZE := 4k
+ PAGESIZE := 256
+ BOARD_NAME := fritz4040
+ DEVICE_TITLE := AVM Fritz!Box 4040
+ IMAGE_SIZE := 29753344
+ IMAGES = sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tffs fritz-caldata u-boot-fritz4040
endef
-TARGET_DEVICES += qcom_ipq8064-db149
+TARGET_DEVICES += avm_fritzbox-4040
define Device/linksys_ea8500
$(call Device/LegacyImage)
@@ -182,20 +132,20 @@ define Device/linksys_ea8500
endef
TARGET_DEVICES += linksys_ea8500
-define Device/avm_fritzbox-4040
- $(call Device/FitImageLzma)
- DEVICE_DTS := qcom-ipq4019-fritz4040
- KERNEL_LOADADDR := 0x80208000
- BLOCKSIZE := 4k
- PAGESIZE := 256
- BOARD_NAME := fritz4040
- DEVICE_TITLE := AVM Fritz!Box 4040
- IMAGE_SIZE := 29753344
- IMAGES = sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tffs fritz-caldata u-boot-fritz4040
+define Device/netgear_d7800
+ $(call Device/DniImage)
+ DEVICE_DTS := qcom-ipq8064-d7800
+ KERNEL_SIZE := 2097152
+ NETGEAR_BOARD_ID := D7800
+ NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := d7800
+ SUPPORTED_DEVICES += d7800
+ DEVICE_TITLE := Netgear Nighthawk X4 D7800
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += avm_fritzbox-4040
+TARGET_DEVICES += netgear_d7800
define Device/netgear_r7500
$(call Device/DniImage)
@@ -242,37 +192,6 @@ define Device/netgear_r7800
endef
TARGET_DEVICES += netgear_r7800
-define Device/zyxel_nbg6817
- DEVICE_DTS := qcom-ipq8065-nbg6817
- KERNEL_SIZE := 4096k
- BLOCKSIZE := 64k
- BOARD_NAME := nbg6817
- SUPPORTED_DEVICES += nbg6817
- DEVICE_TITLE := ZyXEL NBG6817
- DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
- $(call Device/ZyXELImage)
-endef
-TARGET_DEVICES += zyxel_nbg6817
-
-define Device/tplink_vr2600v
- PROFILES += $$(DEVICE_NAME)
- FILESYSTEMS := squashfs
- KERNEL_SUFFIX := -uImage
- KERNEL = kernel-bin | append-dtb | uImage none
- KERNEL_NAME := zImage
- KERNEL_SIZE := 2097152
- DEVICE_DTS := qcom-ipq8064-vr2600v
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- BOARD_NAME := vr2600v
- SUPPORTED_DEVICES += vr2600v
- DEVICE_TITLE := TP-Link Archer VR2600v
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
-endef
-TARGET_DEVICES += tplink_vr2600v
-
define Device/qcom_ap-dk01.1-c1
PROFILES += $$(DEVICE_NAME)
DEVICE_TITLE := QCA AP-DK01.1-C1
@@ -304,4 +223,85 @@ define Device/qcom_ap-dk04.1-c1
endef
TARGET_DEVICES += qcom_ap-dk04.1-c1
+define Device/qcom_ipq8064-ap148
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_DTS := qcom-ipq8064-ap148
+ KERNEL_INSTALL := 1
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := ap148
+ SUPPORTED_DEVICES += ap148
+ DEVICE_TITLE := Qualcomm AP148
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+endef
+TARGET_DEVICES += qcom_ipq8064-ap148
+
+define Device/qcom_ipq8064-ap148-legacy
+ $(call Device/LegacyImage)
+ $(call Device/UbiFit)
+ DEVICE_DTS := qcom-ipq8064-ap148
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := ap148
+ SUPPORTED_DEVICES := qcom,ipq8064-ap148 ap148
+ DEVICE_TITLE := Qualcomm AP148 (legacy)
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+endef
+TARGET_DEVICES += qcom_ipq8064-ap148-legacy
+
+define Device/qcom_ipq8064-db149
+ $(call Device/FitImage)
+ DEVICE_DTS := qcom-ipq8064-db149
+ KERNEL_INSTALL := 1
+ BOARD_NAME := db149
+ DEVICE_TITLE := Qualcomm DB149
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+endef
+TARGET_DEVICES += qcom_ipq8064-db149
+
+define Device/tplink_c2600
+ $(call Device/TpSafeImage)
+ DEVICE_DTS := qcom-ipq8064-c2600
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := c2600
+ SUPPORTED_DEVICES += c2600
+ TPLINK_BOARD_ID := C2600
+ DEVICE_TITLE := TP-Link Archer C2600
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+endef
+TARGET_DEVICES += tplink_c2600
+
+define Device/tplink_vr2600v
+ PROFILES += $$(DEVICE_NAME)
+ FILESYSTEMS := squashfs
+ KERNEL_SUFFIX := -uImage
+ KERNEL = kernel-bin | append-dtb | uImage none
+ KERNEL_NAME := zImage
+ KERNEL_SIZE := 2097152
+ DEVICE_DTS := qcom-ipq8064-vr2600v
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := vr2600v
+ SUPPORTED_DEVICES += vr2600v
+ DEVICE_TITLE := TP-Link Archer VR2600v
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += tplink_vr2600v
+
+define Device/zyxel_nbg6817
+ DEVICE_DTS := qcom-ipq8065-nbg6817
+ KERNEL_SIZE := 4096k
+ BLOCKSIZE := 64k
+ BOARD_NAME := nbg6817
+ SUPPORTED_DEVICES += nbg6817
+ DEVICE_TITLE := ZyXEL NBG6817
+ DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
+ $(call Device/ZyXELImage)
+endef
+TARGET_DEVICES += zyxel_nbg6817
+
$(eval $(call BuildImage))