aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-05-17 16:06:02 +0900
committerMathias Kresin <dev@kresin.me>2018-06-19 20:46:01 +0200
commit4645a6d3183ad27ab1ca74ed82495ac8f6019331 (patch)
tree0d4542d068dc2a65131c3e819ec1e30b36509937 /target/linux/ipq806x/image/Makefile
parent4bb6ee465e4601e60e9624f590f028cc9c4e2f2e (diff)
downloadupstream-4645a6d3183ad27ab1ca74ed82495ac8f6019331.tar.gz
upstream-4645a6d3183ad27ab1ca74ed82495ac8f6019331.tar.bz2
upstream-4645a6d3183ad27ab1ca74ed82495ac8f6019331.zip
ipq806x: add support for NEC Aterm WG2600HP
NEC Aterm WG2600HP is a 2.4/5 GHz band 11ac router, based on Qualcomm IPQ8064. Specification: - IPQ8064 (384 - 1,400 MHz) - 512 MB of RAM - 32 MB of Flash (SPI) - 4T4R 2.4/5 GHz - 5x 10/100/1000 Mbps Ethernet - 12x LEDs, 4x keys - 1x USB 3.0 Type-A - UART header on PCB - RX, TX, NC, GND, Vcc from power connector side - baudrate: 115200 bps Flash instruction using initramfs image: 1. Connect serial cable to UART header 2. Connect power cable and turn on the router 3. When the "Press the [f] key and hit [enter] to enter failsafe mode" message is displayed on the console, press the "f" key and Enter key sequentially to enter the failsafe mode 4. create fw_env.config file with following contents on failsafe mode: /dev/mtd9 0x0 0x10000 0x10000 5. Execute following commands to add and change the environment variables of U-Boot fw_setenv ipaddr "192.168.0.1" fw_setenv serverip "192.168.0.2" fw_setenv autostart "yes" fw_setenv bootcmd "tftpboot 0x44000000 wg2600hp-initramfs.bin; bootipq" 6. Set the IP address of the computer to 192.168.0.2, connect to the LAN port of WG2600HP, and start the TFTP server on the computer 7. Rename OpenWrt initramfs image for WG2600HP to "wg2600hp-initramfs.bin" and place it in the TFTP directory 8. Remove power cable from WG2600HP, reconnect it and restart WG2600HP 9. WG2600HP downloads initramfs image from TFTP server on the computer, loads it and boot with initramfs image 10. On the initramfs image, execute "mtd erase firmware" to erase stock firmware and execute sysupgrade with the sysupgrade image 11. Wait ~180 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index ac57991961..2902af3231 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -101,6 +101,18 @@ define Device/linksys_ea8500
endef
TARGET_DEVICES += linksys_ea8500
+define Device/nec_wg2600hp
+ $(call Device/LegacyImage)
+ DEVICE_DTS := qcom-ipq8064-wg2600hp
+ BLOCKSIZE := 64k
+ BOARD_NAME := wg2600hp
+ DEVICE_TITLE := NEC Aterm WG2600HP
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+endef
+TARGET_DEVICES += nec_wg2600hp
+
define Device/netgear_d7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-d7800