aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2018-05-18 03:49:27 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:34:14 +0200
commit45b8a7c1a6415125f4fe872ec83b3d31a2fa799b (patch)
tree92ae217f95b03faff6474895cd176b6a8778a10a /target/linux/ipq806x/image/Makefile
parent0c967d92b3d9ca34f01f194ad0353f131b42e986 (diff)
downloadupstream-45b8a7c1a6415125f4fe872ec83b3d31a2fa799b.tar.gz
upstream-45b8a7c1a6415125f4fe872ec83b3d31a2fa799b.tar.bz2
upstream-45b8a7c1a6415125f4fe872ec83b3d31a2fa799b.zip
ipq806x: increase kernel partition size for the Netgear Nighthawk X4 D7800
Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the 2 MB reserved for the kernel partition by the OEM firmware anymore. This patch increases the kernel partition from 2 MB to 4 MB, at the expense of the rootfs, for all supported kernels. WARNING: This breaks sysupgrade! Flashing a firmware containing this changed partitioning from an older image with 2 MB reserved for the kernel partion requires the tftp recovery procedure, thereby losing all settings. This change follows the functional example of the Netgear r7800, but has not been runtime tested on a Netgear Nighthawk X4 D7800. Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> Cc: Tathagata Das <tathagata@alumnux.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 8b302b658d..496564de38 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -104,7 +104,7 @@ TARGET_DEVICES += linksys_ea8500
define Device/netgear_d7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-d7800
- KERNEL_SIZE := 2097152
+ KERNEL_SIZE := 4194304
NETGEAR_BOARD_ID := D7800
NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
BLOCKSIZE := 128k