aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2018-05-18 03:34:44 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:34:14 +0200
commit0c967d92b3d9ca34f01f194ad0353f131b42e986 (patch)
treebb257597dff350d22d0cbade75f79aee30dfb439 /target/linux/ipq806x/image/Makefile
parentb72b36653a3fc8347456ab9c45d26a3144688a4c (diff)
downloadupstream-0c967d92b3d9ca34f01f194ad0353f131b42e986.tar.gz
upstream-0c967d92b3d9ca34f01f194ad0353f131b42e986.tar.bz2
upstream-0c967d92b3d9ca34f01f194ad0353f131b42e986.zip
ipq806x: increase kernel partition size for the TP-Link Archer VR2600v
The default image does not fit 2 MB anymore, expand kernel partition to 3 MB. Upgrading should work transparently via sysupgrade in both directions. Another option would be to merge "kernel" and "rootfs" into a single "firmware" partition using MTD_SPLIT_TPLINK_FW, but just changing the sizes of the existing partitioning has been deemed safer in the absence of an actual runtime test on an affected device; the maximum for rootfs changes from 10.4 MB to 9.4 MB. This change follows the example for the TP-Link Archer C2600, but has not been runtime tested on a TP-Link Archer VR2600v. Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> Cc: Sebastian Quilitz <zeraphim@x-pantion.de>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index e5df7275a1..8b302b658d 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -215,7 +215,7 @@ define Device/tplink_vr2600v
KERNEL_SUFFIX := -uImage
KERNEL = kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
- KERNEL_SIZE := 2097152
+ KERNEL_SIZE := 3145728
DEVICE_DTS := qcom-ipq8064-vr2600v
BLOCKSIZE := 128k
PAGESIZE := 2048