aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/Makefile
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-12-30 12:01:41 +0900
committerChristian Lamparter <chunkeey@gmail.com>2019-01-01 15:40:13 +0100
commit250f5ec1397b795e7bdf27dc616842f1ed5cf2ee (patch)
tree38b132b221ad654a48e215d6da246ce9a1209e0f /target/linux/ipq806x/Makefile
parent6734753ef4df50e51c8e3152f49be1d316599441 (diff)
downloadupstream-250f5ec1397b795e7bdf27dc616842f1ed5cf2ee.tar.gz
upstream-250f5ec1397b795e7bdf27dc616842f1ed5cf2ee.tar.bz2
upstream-250f5ec1397b795e7bdf27dc616842f1ed5cf2ee.zip
ipq806x: add ramdisk feature
This commits adds the "ramdisk" feature to ipq806x target. The main driving force behind this decision is to facilitate the installation of OpenWrt on some locked IPQ806x devices. Examples: - NEC Aterm WG2600HP The U-Boot on WG2600HP is protected with a password which prevents users from gaining access to the u-boot prompt in order to install the images from there. Therefore, on this device, installing OpenWrt by the user involves changing the bootcmd as follows so that WG2600HP downloads and executes initramfs image from TFTP server. ex.: bootcmd="ping ${serverip} && tftpboot 0x44000000 wg2600hp-initramfs.bin; bootipq" - Buffalo WXR-2533DHP The U-Boot on WXR-2533DHP has built-in firmware recovery mode. It's activated by holding the "AOSS" button during boot. This will trigger the device to download the firmware from an TFTP server and booting from it. By using this, the user can the install OpenWrt firmware without having access to the UART console. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [reworded commit]
Diffstat (limited to 'target/linux/ipq806x/Makefile')
-rw-r--r--target/linux/ipq806x/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index 129ea2cda5..cd0e8b82ea 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=ipq806x
BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand fpu
+FEATURES:=squashfs nand fpu ramdisk
CPU_TYPE:=cortex-a15
CPU_SUBTYPE:=neon-vfpv4
MAINTAINER:=John Crispin <john@phrozen.org>