aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-17 22:02:40 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-18 16:17:52 +0200
commit8217f02a1c5e2396f083793575de2e79811842e8 (patch)
treea06994c7ed62cc9345dd5272d492532b9bdd7152 /target/linux/ipq40xx
parent4fffa0f6af7944d630687657958c9d872cf67285 (diff)
downloadupstream-8217f02a1c5e2396f083793575de2e79811842e8.tar.gz
upstream-8217f02a1c5e2396f083793575de2e79811842e8.tar.bz2
upstream-8217f02a1c5e2396f083793575de2e79811842e8.zip
ipq-wifi: drop upstreamed board-2.bin
The BDFs for the: Aruba AP-365 Devolo Magic 2 WiFi next Edgecore ECW5410 Edgecore OAP100 Extreme Networks WS-AP3915i GL.iNet GL-A1300 GL.iNet GL-AP1300 GL.iNet GL-S1300 Linksys EA8300 Linksys WHW03v2 Nokia Wi4A AC400i P&W R619AC Pakedge WR-1 Qxwlan E2600AC C1 Sony NCP-HG100/Cellular Teltonika RUTX10 ZTE MF18A were upstreamed to the ath10k-firmware repository and landed in linux-firmware.git. Furthermore the BDFs for the: 8devices Habanero 8devices Jalapeno Qxwlan E2600AC C2 have been updated. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/image/generic.mk30
1 files changed, 10 insertions, 20 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index adce4fe0f2..c8b8ec936b 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -132,7 +132,6 @@ define Device/8dev_habanero-dvk
IMAGE_SIZE := 30976k
SOC := qcom-ipq4019
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
- DEVICE_PACKAGES := ipq-wifi-8dev_habanero
endef
TARGET_DEVICES += 8dev_habanero-dvk
@@ -142,7 +141,6 @@ define Device/8dev_jalapeno-common
BLOCKSIZE := 128k
PAGESIZE := 2048
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-8dev_jalapeno
endef
define Device/8dev_jalapeno
@@ -188,7 +186,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
+ DEVICE_PACKAGES := kmod-hwmon-ad7418
endef
TARGET_DEVICES += aruba_ap-365
@@ -388,7 +386,6 @@ define Device/devolo_magic-2-wifi-next
IMAGE_SIZE := 26624k
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next
DEFAULT := n
endef
# Missing DSA Setup
@@ -443,7 +440,7 @@ define Device/edgecore_oap100
PAGESIZE := 2048
IMAGES := sysupgrade.bin
DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
- DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
+ DEVICE_PACKAGES := kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
endef
# Missing DSA Setup
#TARGET_DEVICES += edgecore_oap100
@@ -540,7 +537,6 @@ define Device/extreme-networks_ws-ap3915i
SOC := qcom-ipq4029
BLOCKSIZE := 128k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
- DEVICE_PACKAGES := ipq-wifi-extreme-networks_ws-ap3915i
endef
TARGET_DEVICES += extreme-networks_ws-ap3915i
@@ -572,7 +568,6 @@ define Device/glinet_gl-a1300
BLOCKSIZE := 128k
PAGESIZE := 2048
IMAGE_SIZE := 131072k
- DEVICE_PACKAGE := ipq-wifi-glinet_gl-a1300
endef
TARGET_DEVICES += glinet_gl-a1300
@@ -587,7 +582,7 @@ define Device/glinet_gl-ap1300
PAGESIZE := 2048
IMAGE_SIZE := 131072k
KERNEL_INSTALL := 1
- DEVICE_PACKAGES := ipq-wifi-glinet_gl-ap1300 kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
endef
TARGET_DEVICES += glinet_gl-ap1300
@@ -630,7 +625,7 @@ define Device/glinet_gl-s1300
IMAGE_SIZE := 26624k
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-glinet_gl-s1300 kmod-fs-ext4 kmod-mmc kmod-spi-dev
+ DEVICE_PACKAGES := kmod-fs-ext4 kmod-mmc kmod-spi-dev
endef
# Missing DSA Setup
#TARGET_DEVICES += glinet_gl-s1300
@@ -697,7 +692,7 @@ define Device/linksys_ea8300
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += linksys_ea8300
@@ -731,7 +726,7 @@ define Device/linksys_whw03v2
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW03v2
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_whw03v2 kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
endef
TARGET_DEVICES += linksys_whw03v2
@@ -935,7 +930,6 @@ define Device/p2w_r619ac
DEVICE_DTS_CONFIG := config@10
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ipq-wifi-p2w_r619ac
endef
define Device/p2w_r619ac-64m
@@ -957,7 +951,6 @@ define Device/pakedge_wr-1
DEVICE_VENDOR := Pakedge
DEVICE_MODEL := WR-1
DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
- DEVICE_PACKAGES := ipq-wifi-pakedge_wr-1
SOC := qcom-ipq4018
BLOCKSIZE := 64k
IMAGE_SIZE := 31232k
@@ -1039,7 +1032,6 @@ define Device/qxwlan_e2600ac-c1
KERNEL_SIZE := 4096k
IMAGE_SIZE := 31232k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c1
DEFAULT := n
endef
# Missing DSA Setup
@@ -1055,7 +1047,6 @@ define Device/qxwlan_e2600ac-c2
KERNEL_INSTALL := 1
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c2
endef
# Missing DSA Setup
#TARGET_DEVICES += qxwlan_e2600ac-c2
@@ -1068,8 +1059,7 @@ define Device/sony_ncp-hg100-cellular
SOC := qcom-ipq4019
KERNEL_SIZE := 8192k
IMAGE_SIZE := 128m
- DEVICE_PACKAGES := e2fsprogs ipq-wifi-sony_ncp-hg100-cellular \
- kmod-fs-ext4 uqmi
+ DEVICE_PACKAGES := e2fsprogs kmod-fs-ext4 uqmi
endef
TARGET_DEVICES += sony_ncp-hg100-cellular
@@ -1085,7 +1075,7 @@ define Device/teltonika_rutx10
PAGESIZE := 2048
FILESYSTEMS := squashfs
IMAGE/factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
- DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
+ DEVICE_PACKAGES := kmod-bluetooth
endef
# Missing DSA Setup
#TARGET_DEVICES += teltonika_rutx10
@@ -1141,7 +1131,7 @@ define Device/zte_mf18a
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_IN_UBI := 1
- DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct ipq-wifi-zte_mf18a
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += zte_mf18a
@@ -1165,7 +1155,7 @@ TARGET_DEVICES += zte_mf286d
define Device/zte_mf289f
$(call Device/zte_mf28x_common)
DEVICE_MODEL := MF289F
- DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
+ DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
endef
TARGET_DEVICES += zte_mf289f