aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2021-11-30 10:25:52 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-05-19 11:07:02 +0200
commitab141a6e2cb645ff64adb107af2e8973a720c1c7 (patch)
tree4952e7caa293601dce1bce5125137e3873b84a77 /target/linux/ipq40xx
parent4d4462cc2ace4b044e99e9b22a24cb4d89c7db95 (diff)
downloadupstream-ab141a6e2cb645ff64adb107af2e8973a720c1c7.tar.gz
upstream-ab141a6e2cb645ff64adb107af2e8973a720c1c7.tar.bz2
upstream-ab141a6e2cb645ff64adb107af2e8973a720c1c7.zip
ipq-wifi: remove packaged BDF-s for MikroTik devices
Since we now provide the BDF-s for MikroTik IPQ40xx devices on the fly, there is noneed to include package and ship them like we do now. This also resolves the performance issues that happen as MikroTik changes the boards and ships them under the same revision but they actually ship with and require a different BDF. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index 037a042848..b2e8428e94 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -24,8 +24,7 @@ define Device/mikrotik_cap-ac
$(call Device/mikrotik_nor)
DEVICE_MODEL := cAP ac
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-mikrotik_cap-ac -kmod-ath10k-ct \
- kmod-ath10k-ct-smallbuffers
+ DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += mikrotik_cap-ac
@@ -33,8 +32,7 @@ define Device/mikrotik_hap-ac2
$(call Device/mikrotik_nor)
DEVICE_MODEL := hAP ac2
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-mikrotik_hap-ac2 -kmod-ath10k-ct \
- kmod-ath10k-ct-smallbuffers
+ DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += mikrotik_hap-ac2
@@ -45,7 +43,7 @@ define Device/mikrotik_hap-ac3
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_UBIFS_OPTS = -m $$(PAGESIZE) -e 124KiB -c $$(PAGESIZE) -x none
- DEVICE_PACKAGES := kmod-ledtrig-gpio ipq-wifi-mikrotik_hap-ac3
+ DEVICE_PACKAGES := kmod-ledtrig-gpio
endef
TARGET_DEVICES += mikrotik_hap-ac3
@@ -61,6 +59,6 @@ define Device/mikrotik_sxtsq-5-ac
$(call Device/mikrotik_nor)
DEVICE_MODEL := SXTsq 5 ac (RBSXTsqG-5acD)
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-mikrotik_sxtsq-5-ac rssileds
+ DEVICE_PACKAGES := rssileds
endef
TARGET_DEVICES += mikrotik_sxtsq-5-ac