aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorDavide Fioravanti <pantanastyle@gmail.com>2022-10-04 23:20:39 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-25 02:34:46 +0200
commit8d921167e974fd98d35959559a0dbafd3400f7ec (patch)
tree71b86cda29683dbdfb37357ff053ab9b4dff8a2f /target/linux/ipq40xx
parentea63945b254ccd0560c46ff86766bd7a6772e809 (diff)
downloadupstream-8d921167e974fd98d35959559a0dbafd3400f7ec.tar.gz
upstream-8d921167e974fd98d35959559a0dbafd3400f7ec.tar.bz2
upstream-8d921167e974fd98d35959559a0dbafd3400f7ec.zip
ipq40xx: convert to DSA and enable Netgear Orbi devices
Convert to DSA and enable again Netgear Orbi devices: - RBR50 - RBS50 - SRR60 - SRS60 Signed-off-by: Davide Fioravanti <pantanastyle@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/base-files/etc/board.d/02_network10
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-orbi.dtsi37
-rw-r--r--target/linux/ipq40xx/image/generic.mk12
3 files changed, 51 insertions, 8 deletions
diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
index 57c228e123..c24e4c8373 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
+++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
@@ -64,6 +64,12 @@ ipq40xx_setup_interfaces()
mikrotik,wap-ac)
ucidef_set_interface_lan "sw-eth1 sw-eth2"
;;
+ netgear,rbr50|\
+ netgear,rbs50|\
+ netgear,srr60|\
+ netgear,srs60)
+ ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
+ ;;
zte,mf286d)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" "wan"
;;
@@ -142,6 +148,10 @@ ipq40xx_setup_macs()
lan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
label_mac="$lan_mac"
;;
+ netgear,rbr50|\
+ netgear,rbs50|\
+ netgear,srr60|\
+ netgear,srs60|\
pakedge,wr-1)
wan_mac=$(macaddr_add $(get_mac_label) 1)
;;
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-orbi.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-orbi.dtsi
index 4a575b60ee..44dbfef529 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-orbi.dtsi
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-orbi.dtsi
@@ -11,6 +11,7 @@
led-failsafe = &led_status_red;
led-running = &led_status_green;
led-upgrade = &led_status_blue;
+ label-mac-device = &gmac;
};
soc {
@@ -266,6 +267,42 @@
status = "okay";
};
+&gmac {
+ status = "okay";
+};
+
+&switch {
+ status = "okay";
+};
+
+&swport1 {
+ status = "okay";
+
+ label = "wan";
+};
+
+&swport2 {
+ status = "okay";
+
+ label = "lan1";
+};
+
+&swport3 {
+ status = "okay";
+
+ label = "lan2";
+};
+
+&swport4 {
+ status = "okay";
+
+ label = "lan3";
+};
+
+&ethphy4 {
+ status = "disabled";
+};
+
&pcie0 {
status = "okay";
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index fd3140c2aa..e8e6e29e72 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -815,8 +815,7 @@ define Device/netgear_rbr50
DEVICE_VARIANT := v1
NETGEAR_BOARD_ID := RBR50
endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_rbr50
+TARGET_DEVICES += netgear_rbr50
define Device/netgear_rbs50
$(call Device/netgear_rbx50)
@@ -824,8 +823,7 @@ define Device/netgear_rbs50
DEVICE_VARIANT := v1
NETGEAR_BOARD_ID := RBS50
endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_rbs50
+TARGET_DEVICES += netgear_rbs50
define Device/netgear_srx60
$(call Device/netgear_orbi)
@@ -840,16 +838,14 @@ define Device/netgear_srr60
DEVICE_MODEL := SRR60
NETGEAR_BOARD_ID := SRR60
endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_srr60
+TARGET_DEVICES += netgear_srr60
define Device/netgear_srs60
$(call Device/netgear_srx60)
DEVICE_MODEL := SRS60
NETGEAR_BOARD_ID := SRS60
endef
-# Missing DSA Setup
-#TARGET_DEVICES += netgear_srs60
+TARGET_DEVICES += netgear_srs60
define Device/netgear_wac510
$(call Device/FitImage)