aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-11-17 02:03:59 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-11-24 16:46:28 +0000
commit87fc4854505fc459e9e9bedb7474f47d84077ab0 (patch)
treed382b4464d2c92be7e3cc0ef2dc4e36d9e034be4 /target/linux/ipq40xx
parentd9f7c751c9772772473d226b1088e8dec31f3090 (diff)
downloadupstream-87fc4854505fc459e9e9bedb7474f47d84077ab0.tar.gz
upstream-87fc4854505fc459e9e9bedb7474f47d84077ab0.tar.bz2
upstream-87fc4854505fc459e9e9bedb7474f47d84077ab0.zip
ipq40xx: remove '-fit' string from kernel filenames
The type of those images is already distinguishable by the '.itb' extension, there is no need for an additional '-fit' string in the filenames. Remove it to behave more like other targets. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/image/generic.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 1e5087bd24..290581ac80 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -4,19 +4,19 @@ DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
DEVICE_VARS += WRGG_DEVNAME WRGG_SIGNATURE
define Device/FitImage
- KERNEL_SUFFIX := -fit-uImage.itb
+ KERNEL_SUFFIX := -uImage.itb
KERNEL = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_NAME := Image
endef
define Device/FitImageLzma
- KERNEL_SUFFIX := -fit-uImage.itb
+ KERNEL_SUFFIX := -uImage.itb
KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_NAME := Image
endef
define Device/FitzImage
- KERNEL_SUFFIX := -fit-zImage.itb
+ KERNEL_SUFFIX := -zImage.itb
KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_NAME := zImage
endef
@@ -312,7 +312,7 @@ endef
#TARGET_DEVICES += buffalo_wtr-m2133hp
define Device/cellc_rtl30vw
- KERNEL_SUFFIX := -fit-zImage.itb
+ KERNEL_SUFFIX := -zImage.itb
KERNEL_INITRAMFS = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb | uImage lzma | pad-to 2048
KERNEL_NAME := zImage