aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-05-25 22:07:10 +0200
committerDavid Bauer <mail@david-bauer.net>2022-06-02 17:01:22 +0200
commitf765f2f114f4ad51bf1c77bbe8270e6533fce7d5 (patch)
treeed98fa8e467d0144e0c5b5cfa67c2c88b1a3a8dd /target/linux/ipq40xx
parent59e1b59bb327cd5c5c617a52b30841150da1ea5e (diff)
downloadupstream-f765f2f114f4ad51bf1c77bbe8270e6533fce7d5.tar.gz
upstream-f765f2f114f4ad51bf1c77bbe8270e6533fce7d5.tar.bz2
upstream-f765f2f114f4ad51bf1c77bbe8270e6533fce7d5.zip
ipq40xx: add Aruba AP-365 specific BDF
Aruba deploys a BDF in the root filesystem, however this matches the one used for the DK04 reference board. The board-specific BDFs are built into the kernel. The AP-365 shows sinificant degraded performance with increased range when used with the reference BDF. Replace the BDF with the one extracted from Arubas kernel. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit b21b98627dcd6c1868d13964f6d84e8d43ae9ef7)
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts9
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
index d3cc73f388..1f7b37d56d 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
@@ -208,3 +208,12 @@
};
};
};
+
+&wifi0 {
+ qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
+&wifi1 {
+ qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 5eac14e0ae..0112e18ac0 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -187,7 +187,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES += kmod-hwmon-ad7418
+ DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
endef
TARGET_DEVICES += aruba_ap-365