aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-09-26 17:49:35 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-26 18:26:19 +0200
commit4682d4d77075775f54363dbad8898a501705da80 (patch)
treec9c4718bd8d21c63d45c9097037eb2ac196e8352 /target/linux/ipq40xx
parent621297e86736556f772a3a1e3907c4ad9223bd74 (diff)
downloadupstream-4682d4d77075775f54363dbad8898a501705da80.tar.gz
upstream-4682d4d77075775f54363dbad8898a501705da80.tar.bz2
upstream-4682d4d77075775f54363dbad8898a501705da80.zip
ipq40xx: tidy up device recipe for Edgecore OAP100
* split up DEVICE_TITLE into DEVICE_{VENDOR,MODEL} * use SOC instead of DEVICE_DTS Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 77d4d52ec0..6e5620a140 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -359,12 +359,13 @@ TARGET_DEVICES += edgecore_ecw5211
define Device/edgecore_oap100
$(call Device/FitImage)
$(call Device/UbiFit)
- DEVICE_TITLE := Edgecore OAP100
+ DEVICE_VENDOR := Edgecore
+ DEVICE_MODEL := OAP100
+ SOC := qcom-ipq4019
BLOCKSIZE := 128k
PAGESIZE := 2048
IMAGES := nand-sysupgrade.bin
DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
- DEVICE_DTS := qcom-ipq4019-oap100
DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
endef
TARGET_DEVICES += edgecore_oap100