aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2021-09-12 23:50:20 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-25 19:28:54 +0200
commitf4fb63d2ab4f152fa2950ce7a77cabd16f757d06 (patch)
treedb7941b6268416d5dc79ac779442ddb03b059afc /target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
parentccf214a408592f1783be6e20175105c64b5ddb81 (diff)
downloadupstream-f4fb63d2ab4f152fa2950ce7a77cabd16f757d06.tar.gz
upstream-f4fb63d2ab4f152fa2950ce7a77cabd16f757d06.tar.bz2
upstream-f4fb63d2ab4f152fa2950ce7a77cabd16f757d06.zip
ipq40xx: 5.10: move AR40xx to MDIO drivers
MDIO drivers were moved into their own sub directory of networking drivers. This has caused the AR40xx driver to probe before MDIO drivers and that wont work as it depends on the MDIO bus to be up so it can be fetched. Lets solve it by moving the AR40xx into MDIO folder so they get probed like before. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch')
-rw-r--r--target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch45
1 files changed, 23 insertions, 22 deletions
diff --git a/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch b/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
index 6b0272bd72..cd0b10c6c8 100644
--- a/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
+++ b/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
@@ -1,26 +1,27 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -388,6 +388,13 @@ config XILINX_GMII2RGMII
- the Reduced Gigabit Media Independent Interface(RGMII) between
- Ethernet physical media devices and the Gigabit Ethernet controller.
+--- a/drivers/net/mdio/Kconfig
++++ b/drivers/net/mdio/Kconfig
+@@ -27,6 +27,13 @@ config OF_MDIO
+ help
+ OpenFirmware MDIO bus (Ethernet PHY) accessors
+config AR40XX_PHY
-+ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
-+ depends on HAS_IOMEM && OF && OF_MDIO
-+ select SWCONFIG
-+ help
-+ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
++ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
++ depends on HAS_IOMEM && OF && OF_MDIO
++ select SWCONFIG
++ help
++ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
+
- endif # PHYLIB
+ if MDIO_BUS
- config MICREL_KS8995MA
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -50,6 +50,7 @@ ifdef CONFIG_HWMON
- aquantia-objs += aquantia_hwmon.o
- endif
- obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
-+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
- obj-$(CONFIG_AT803X_PHY) += at803x.o
- obj-$(CONFIG_AX88796B_PHY) += ax88796b.o
- obj-$(CONFIG_BCM54140_PHY) += bcm54140.o
+ config MDIO_DEVRES
+--- a/drivers/net/mdio/Makefile
++++ b/drivers/net/mdio/Makefile
+@@ -21,6 +21,8 @@ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.
+ obj-$(CONFIG_MDIO_THUNDER) += mdio-thunder.o
+ obj-$(CONFIG_MDIO_XGENE) += mdio-xgene.o
+
++obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
++
+ obj-$(CONFIG_MDIO_BUS_MUX) += mdio-mux.o
+ obj-$(CONFIG_MDIO_BUS_MUX_BCM_IPROC) += mdio-mux-bcm-iproc.o
+ obj-$(CONFIG_MDIO_BUS_MUX_GPIO) += mdio-mux-gpio.o