aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2021-09-13 14:08:35 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-25 19:28:54 +0200
commit8f27ac5ec066e6cc85013eb49150aa5d7144de33 (patch)
treef940932a4b0ee58d0048a8af3c0f18d3ae2a2a63 /target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
parent7ff0efa0b0dc5719b19ffafcee5544f55f05be4b (diff)
downloadupstream-8f27ac5ec066e6cc85013eb49150aa5d7144de33.tar.gz
upstream-8f27ac5ec066e6cc85013eb49150aa5d7144de33.tar.bz2
upstream-8f27ac5ec066e6cc85013eb49150aa5d7144de33.zip
ipq40xx: 5.10: copy patches
Copy over the 5.4 kernel patches to 5.10 folder. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch')
-rw-r--r--target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch b/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
new file mode 100644
index 0000000000..9adddcabc3
--- /dev/null
+++ b/target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -584,6 +584,13 @@ config XILINX_GMII2RGMII
+ the Reduced Gigabit Media Independent Interface(RGMII) between
+ Ethernet physical media devices and the Gigabit Ethernet controller.
+
++config AR40XX_PHY
++ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
++ depends on HAS_IOMEM && OF && OF_MDIO
++ select SWCONFIG
++ help
++ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -69,6 +69,7 @@ ifdef CONFIG_HWMON
+ aquantia-objs += aquantia_hwmon.o
+ endif
+ obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
++obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
+ obj-$(CONFIG_AX88796B_PHY) += ax88796b.o
+ obj-$(CONFIG_AT803X_PHY) += at803x.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o