aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2022-11-12 12:13:46 +0000
committerAlexander Couzens <lynxis@fe80.eu>2022-11-27 13:28:22 +0000
commitd4c460648dc28a7e8f2082101159971f6858c743 (patch)
tree12a11cdb8c0dc67460c9ab46e2a8d74aa62396b9 /target/linux/ipq40xx/image
parentbb2fb4f16aef574921cb75e2205b2a3c38822588 (diff)
downloadupstream-d4c460648dc28a7e8f2082101159971f6858c743.tar.gz
upstream-d4c460648dc28a7e8f2082101159971f6858c743.tar.bz2
upstream-d4c460648dc28a7e8f2082101159971f6858c743.zip
ipq40xx: add support for Mikrotik wAP R ac / LTE / LTE6
The Mikrotik wAP R AC is an outdoor, dual band, dual radio (802.11ac) AP with a miniPCIe slot for a LTE modem. The wAP R AC is similar to the wAP AC but with the miniPCIe slot. The wAP R AC requires installing a LTE modem. The wAP LTE and wAP LTE6 comes with a LTE modem installed. See https://mikrotik.com/product/wap_r_ac for more info. Specifications: - SoC: Qualcomm Atheros IPQ4018 - CPU: 4x ARM Cortex A7 - RAM: 128MB - Storage: 16MB NOR flash - Wireless: - Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, internal antenna - Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, internal antenna - Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 2x 1000/100/10 ports one with 802.3af/at PoE in - 1x Mini PCI-E port (USB2) Installation: Boot the initramfs image via TFTP, then flash the sysupgrade image using sysupgrade. Details at https://openwrt.org/toh/mikrotik/common. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index 3eacedd9d8..f0e1f1aad3 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -78,3 +78,23 @@ define Device/mikrotik_wap-ac
DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += mikrotik_wap-ac
+
+define Device/mikrotik_wap-r-ac
+ $(call Device/mikrotik_wap-ac)
+ DEVICE_MODEL := wAP R ac
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi \
+ kmod-usb-acm kmod-usb-net-rndis
+ DEVICE_DTS := qcom-ipq4018-wap-r-ac
+endef
+TARGET_DEVICES += mikrotik_wap-r-ac
+
+define Device/mikrotik_wap-ac-lte
+ $(call Device/mikrotik_wap-ac)
+ DEVICE_MODEL := wAP ac LTE
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi \
+ kmod-usb-acm kmod-usb-net-rndis
+ DEVICE_DTS := qcom-ipq4018-wap-ac-lte
+ DEVICE_ALT0_VENDOR = Mikrotik
+ DEVICE_ALT0_MODEL := wAP ac LTE6
+endef
+TARGET_DEVICES += mikrotik_wap-ac-lte