aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorMatthew Hagan <mnhagan88@gmail.com>2022-06-14 10:08:22 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-06-19 12:31:02 +0200
commit811538ab2240f3d0a62312f0050b607f1154bf47 (patch)
tree4d98e341ff47daefca7600fc70a2442068c11afe /target/linux/ipq40xx/image
parent5f7828fcc274ec7c381298c92cf3a946182168a0 (diff)
downloadupstream-811538ab2240f3d0a62312f0050b607f1154bf47.tar.gz
upstream-811538ab2240f3d0a62312f0050b607f1154bf47.tar.bz2
upstream-811538ab2240f3d0a62312f0050b607f1154bf47.zip
ipq40xx: add support for Meraki MR74
The Meraki MR74 is part of the "Insect" series. This device is essentially an outdoor variant of the MR33 with identical hardware, but requiring a config@3 DTS option to be set to allow booting with the stock u-boot. The install procedure is replicated from the MR33, with the exception being that the MR74 sysupgrade image must be used. Signed-off-by: Matthew Hagan <mnhagan88@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 0ddff52ef8..26d9082638 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -704,6 +704,18 @@ define Device/meraki_mr33
endef
TARGET_DEVICES += meraki_mr33
+define Device/meraki_mr74
+ $(call Device/FitImage)
+ DEVICE_VENDOR := Cisco Meraki
+ DEVICE_MODEL := MR74
+ SOC := qcom-ipq4029
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+ DEVICE_DTS_CONFIG := config@3
+endef
+TARGET_DEVICES += meraki_mr74
+
define Device/mobipromo_cm520-79f
$(call Device/FitzImage)
$(call Device/UbiFit)