aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorAndreas Böhler <dev@aboehler.at>2023-09-16 21:55:01 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-24 12:55:18 +0200
commita684b512e56662ac6b151e5aa44367a7d9171a50 (patch)
tree0c52e3d84859180bed213e397deac8c2c4b999f6 /target/linux/ipq40xx/image
parent2f30dec3cbe56eca9f310922b6b694b3d6d57c5d (diff)
downloadupstream-a684b512e56662ac6b151e5aa44367a7d9171a50.tar.gz
upstream-a684b512e56662ac6b151e5aa44367a7d9171a50.tar.bz2
upstream-a684b512e56662ac6b151e5aa44367a7d9171a50.zip
ipq40xx: refactor ZTE MF287 series
The ZTE MF287 requires a different board calibration file for ath10k than the ZTE MF287+. The two devices receive their own DTS, thus the device tree is slightly refactored. Signed-off-by: Andreas Böhler <dev@aboehler.at> (cherry picked from commit 9c7578d560708c040dc04d0db37ef682db58f6b5)
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/generic.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 08cbd63b3c..99a9b78b78 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1164,7 +1164,6 @@ TARGET_DEVICES += zte_mf286d
define Device/zte_mf287_common
$(call Device/zte_mf28x_common)
- DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
SOC := qcom-ipq4018
# The recovery image is used to return back to stock (an initramfs-based image
# that can be flashed to the device via sysupgrade
@@ -1177,15 +1176,23 @@ endef
define Device/zte_mf287plus
$(call Device/zte_mf287_common)
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
DEVICE_MODEL := MF287Plus
- DEVICE_ALT0_VENDOR := ZTE
- DEVICE_ALT0_MODEL := MF287
endef
TARGET_DEVICES += zte_mf287plus
+define Device/zte_mf287
+ $(call Device/zte_mf287_common)
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+ DEVICE_MODEL := MF287
+endef
+TARGET_DEVICES += zte_mf287
+
define Device/zte_mf287pro
$(call Device/zte_mf287_common)
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
DEVICE_MODEL := MF287Pro
endef