aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2020-06-30 18:07:50 +0200
committerKoen Vandeputte <koen.vandeputte@citymesh.com>2023-03-21 16:38:23 +0100
commiteb564690c995b284204aa762c0f77f3064419a9c (patch)
tree8ce52f1b463ceb2e539e717fc2f8c6824f9b6548 /target/linux/ipq40xx/image
parent7699a5b1d77bcab3d63f6fb94b6f89f093db6395 (diff)
downloadupstream-eb564690c995b284204aa762c0f77f3064419a9c.tar.gz
upstream-eb564690c995b284204aa762c0f77f3064419a9c.tar.bz2
upstream-eb564690c995b284204aa762c0f77f3064419a9c.zip
ipq40xx: add support for Wallystech DR40x9
Adds support for the Wallys DR40x9 series boards. They come in IPQ4019 and IPQ4029 versions. IPQ4019/4029 only differ in that that IPQ4029 is the industrial version that is rated to higher temperatures. Specifications are: * CPU: Qualcomm IPQ40x9 (4x ARMv7A Cortex A7) at 716 MHz * RAM: 512 MB * Storage: 2MB of SPI-NOR, 128 MB of parallel NAND * USB 3.0 TypeA port for users * MiniPCI-E with PCI-E 2.0 link * MiniPCI-E for LTE modems with only USB2.0 link * 2 SIM card slots that are selected via GPIO11 * MicroSD card slot * Ethernet: 2x GBe with 24~48V passive POE * SFP port (Does not work, I2C and GPIO's not connected on hardware) * DC Jack * UART header * WLAN: In-SoC 2x2 802.11b/g/n and 2x2 802.11a/n/ac * 4x MMCX connectors for WLAN * Reset button * 8x LED-s Installation instructions: Connect to UART, pins are like this: -> 3.3V | TX | RX | GND Settings are 115200 8n1 Boot initramfs from TFTP: tftpboot 0x84000000 openwrt-ipq40xx-generic-wallys_dr40x9-initramfs-fit-uImage.itb bootm Then copy the sysupgrade image to the /tmp folder and execute sysupgrade -n <image_name> The board file binary was provided from Wallystech on March 14th 2023 including full permission to use and distribute. Signed-off-by: Robert Marko <robert.marko@sartura.hr> Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 68a45dbf9b..48514b8841 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1122,6 +1122,19 @@ endef
# Missing DSA Setup
#TARGET_DEVICES += unielec_u4019-32m
+define Device/wallys_dr40x9
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Wallys
+ DEVICE_MODEL := DR40X9
+ SOC := qcom-ipq40x9
+ DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_PACKAGES := ipq-wifi-wallys_dr40x9
+endef
+TARGET_DEVICES += wallys_dr40x9
+
define Device/zte_mf18a
$(call Device/FitImage)
DEVICE_VENDOR := ZTE